aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-18 11:40:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:42:58 +0300
commitec1cb768712a98868c75ec9fafafcacbe775d087 (patch)
tree2f6603efdf259aee8ce3531219b6df6b874ad296 /gnu/packages/crates-web.scm
parentc834a4f7f4447f1f0a0a76fbb41131115173bc3e (diff)
downloadguix-ec1cb768712a98868c75ec9fafafcacbe775d087.tar.gz
guix-ec1cb768712a98868c75ec9fafafcacbe775d087.zip
gnu: Add rust-actix-tls-3.
* gnu/packages/crates-web.scm (rust-actix-tls-3): New variable. (rust-actix-tls-2): Inherit from rust-actix-tls-3. Change-Id: I93d614318507deb1ecb2ed9e9d44e984daee05f1
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm54
1 files changed, 47 insertions, 7 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 942a4122b5..634c3d3ddb 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -1243,8 +1243,54 @@ asynchronous request/response operations.")
("rust-parking-lot" ,rust-parking-lot-0.9)
("rust-threadpool" ,rust-threadpool-1))))))
+(define-public rust-actix-tls-3
+ (package
+ (name "rust-actix-tls")
+ (version "3.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "actix-tls" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0pxyqpr5nangbl55gdc5zpc84viah7qhmpjw5v3pnirb5w5fdk6l"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; use of undeclared crate or module `actix_server`
+ #:cargo-inputs (("rust-actix-rt" ,rust-actix-rt-2)
+ ("rust-actix-service" ,rust-actix-service-2)
+ ("rust-actix-utils" ,rust-actix-utils-3)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-http" ,rust-http-1)
+ ("rust-impl-more" ,rust-impl-more-0.1)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
+ ("rust-rustls" ,rust-rustls-0.21)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.7)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
+ ("rust-rustls-pki-types" ,rust-rustls-pki-types-1)
+ ("rust-rustls-webpki" ,rust-rustls-webpki-0.101)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
+ ("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.25)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.23)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.24)
+ ("rust-tokio-util" ,rust-tokio-util-0.7)
+ ("rust-tracing" ,rust-tracing-0.1)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.25)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.22)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.26))))
+ (home-page "https://github.com/actix/actix-net")
+ (synopsis "TLS acceptor services for Actix ecosystem")
+ (description
+ "This package provides TLS acceptor services for Actix ecosystem.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-actix-tls-2
(package
+ (inherit rust-actix-tls-3)
(name "rust-actix-tls")
(version "2.0.0")
(source
@@ -1254,7 +1300,6 @@ asynchronous request/response operations.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1yqmlyn02c72a1rrmjkfx5hnz286130y3sq4ll1mbkv1fdyrny14"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -1269,12 +1314,7 @@ asynchronous request/response operations.")
("rust-tokio-rustls" ,rust-tokio-rustls-0.14)
("rust-tokio-tls" ,rust-tokio-tls-0.3)
("rust-webpki" ,rust-webpki-0.21)
- ("rust-webpki-roots" ,rust-webpki-roots-0.20))))
- (home-page "https://actix.rs")
- (synopsis "TLS acceptor services for Actix ecosystem")
- (description
- "This package provides TLS acceptor services for Actix ecosystem.")
- (license (list license:expat license:asl2.0))))
+ ("rust-webpki-roots" ,rust-webpki-roots-0.20))))))
(define-public rust-actix-tls-1
(package