aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-19 16:40:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:43:44 +0300
commit557068ee7cf0eb5d382c093be992c25823955afa (patch)
tree064bebd1e35ee802805fe11f2a6a89a632c8e567 /gnu/packages/crates-web.scm
parent31da99a9c767f3e7b26853ed1e8502245d455da3 (diff)
downloadguix-557068ee7cf0eb5d382c093be992c25823955afa.tar.gz
guix-557068ee7cf0eb5d382c093be992c25823955afa.zip
gnu: rust-trust-dns-resolver-0.18: Downgrade to 0.18.0-alpha.2.
* gnu/packages/crates-web.scm (rust-trust-dns-resolver-0.18): Downgrade to 0.18.0-alpha.2. [arguments]: Don't skip the tests. Add cargo-test-flags. [cargo-inputs]: Replace rust-trust-dns-https-0.18 with 0.18.0-alpha.2, rust-trust-dns-native-tls-0.18 with 0.18.0-alpha.2, rust-trust-dns-openssl-0.18 with 0.18.0-alpha.2, rust-trust-dns-proto-0.18 with 0.18.0-alpha.2, rust-trust-dns-rustls-0.18 with 0.18.0-alpha.2. Change-Id: If0c0a20caf15746b24eee426247536f840861f55
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm32
1 files changed, 23 insertions, 9 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 0b58a3f19b..c119efaf93 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -6551,21 +6551,35 @@ other queries.")
(("rust-env-logger" ,rust-env-logger-0.7)
("rust-futures" ,rust-futures-0.3))))))
-(define-public rust-trust-dns-resolver-0.18
+(define-public rust-trust-dns-resolver-0.18.0-alpha.2
(package
(inherit rust-trust-dns-resolver-0.19)
(name "rust-trust-dns-resolver")
- (version "0.18.1")
+ (version "0.18.0-alpha.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "trust-dns-resolver" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0cldg6y937il4kjk7rirgfhmk0chz41w7qys9h96skaznh4dzmvj"))))
+ (base32 "0bsal2vz7q3fqdyxa0j1rbbh1hm8mxxv7mf62hjqnvr25d8b343g"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #false ;network unreachable
+ `(#:cargo-test-flags
+ '("--release" "--lib" "--bins" "--tests" "--"
+ "--skip=async_resolver::tests::test_domain_search"
+ "--skip=async_resolver::tests::test_fqdn"
+ "--skip=async_resolver::tests::test_idna"
+ "--skip=async_resolver::tests::test_large_ndots"
+ "--skip=async_resolver::tests::test_lookup_cloudflare"
+ "--skip=async_resolver::tests::test_lookup_google"
+ "--skip=async_resolver::tests::test_lookup_quad9"
+ "--skip=async_resolver::tests::test_ndots"
+ "--skip=async_resolver::tests::test_search_list"
+ "--skip=hosts::tests::test_read_hosts_conf"
+ "--skip=name_server::name_server::tests::test_name_server"
+ "--skip=resolver::tests::test_lookup"
+ "--skip=system_conf::unix::tests::test_read_resolv_conf")
#:cargo-inputs
(("rust-cfg-if" ,rust-cfg-if-0.1)
("rust-failure" ,rust-failure-0.1)
@@ -6579,11 +6593,11 @@ other queries.")
("rust-serde" ,rust-serde-1)
("rust-smallvec" ,rust-smallvec-1)
("rust-tokio" ,rust-tokio-0.2)
- ("rust-trust-dns-https" ,rust-trust-dns-https-0.18)
- ("rust-trust-dns-native-tls" ,rust-trust-dns-native-tls-0.18)
- ("rust-trust-dns-openssl" ,rust-trust-dns-openssl-0.18)
- ("rust-trust-dns-proto" ,rust-trust-dns-proto-0.18)
- ("rust-trust-dns-rustls" ,rust-trust-dns-rustls-0.18)
+ ("rust-trust-dns-https" ,rust-trust-dns-https-0.18.0-alpha.2)
+ ("rust-trust-dns-native-tls" ,rust-trust-dns-native-tls-0.18.0-alpha.2)
+ ("rust-trust-dns-openssl" ,rust-trust-dns-openssl-0.18.0-alpha.2)
+ ("rust-trust-dns-proto" ,rust-trust-dns-proto-0.18.0-alpha.2)
+ ("rust-trust-dns-rustls" ,rust-trust-dns-rustls-0.18.0-alpha.2)
("rust-webpki-roots" ,rust-webpki-roots-0.18))
#:cargo-development-inputs
(("rust-env-logger" ,rust-env-logger-0.7)