aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-vcs.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-27 10:05:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:44:18 +0300
commit9329a30434510a4c1d555ee762dce4a3925e88c8 (patch)
tree8cb6429aa9002fd498e8d941f9bfcef17a423d66 /gnu/packages/crates-vcs.scm
parent57dc2b6ac1868a4b24cde4ff17698db33ef623df (diff)
downloadguix-9329a30434510a4c1d555ee762dce4a3925e88c8.tar.gz
guix-9329a30434510a4c1d555ee762dce4a3925e88c8.zip
gnu: Add rust-gix-worktree-state-0.6.
* gnu/packages/crates-vcs.scm (rust-gix-worktree-state-0.6): New variable. (rust-gix-worktree-state-0.5): Inherit from rust-gix-worktree-state-0.6. Change-Id: I94fd10c8dcc2d4be7a41f2d1e69bc7c94ba946e7
Diffstat (limited to 'gnu/packages/crates-vcs.scm')
-rw-r--r--gnu/packages/crates-vcs.scm44
1 files changed, 35 insertions, 9 deletions
diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
index 9453c18b41..f0160f0e1a 100644
--- a/gnu/packages/crates-vcs.scm
+++ b/gnu/packages/crates-vcs.scm
@@ -4633,8 +4633,42 @@ types and utilities. Part of Gitoxide a pure Rust implementation of Git.")
("rust-tempfile" ,rust-tempfile-3)
("rust-walkdir" ,rust-walkdir-2))))))
+(define-public rust-gix-worktree-state-0.6
+ (package
+ (name "rust-gix-worktree-state")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-worktree-state" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1890rq778ac6va1pki0d4379mpinirs892z71hvm3h1449rlxiyq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+ ("rust-gix-features" ,rust-gix-features-0.37)
+ ("rust-gix-filter" ,rust-gix-filter-0.8)
+ ("rust-gix-fs" ,rust-gix-fs-0.9)
+ ("rust-gix-glob" ,rust-gix-glob-0.15)
+ ("rust-gix-hash" ,rust-gix-hash-0.14)
+ ("rust-gix-index" ,rust-gix-index-0.28)
+ ("rust-gix-object" ,rust-gix-object-0.40)
+ ("rust-gix-path" ,rust-gix-path-0.10)
+ ("rust-gix-worktree" ,rust-gix-worktree-0.29)
+ ("rust-io-close" ,rust-io-close-0.3)
+ ("rust-thiserror" ,rust-thiserror-1))))
+ (home-page "https://github.com/Byron/gitoxide")
+ (synopsis
+ "Gitoxide project functions that set Git's worktree to a particular state")
+ (description
+ "This package provides functions for setting the Git worktree to a particular
+state. Used by Gitoxide a pure Rust implementation of Git.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-gix-worktree-state-0.5
(package
+ (inherit rust-gix-worktree-state-0.6)
(name "rust-gix-worktree-state")
(version "0.5.0")
(source
@@ -4644,7 +4678,6 @@ types and utilities. Part of Gitoxide a pure Rust implementation of Git.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "00gsa6vzxc8ya5h9yp33wa668ak6ah95llcilfycy331zqf3rvxg"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
("rust-gix-features" ,rust-gix-features-0.36)
@@ -4657,14 +4690,7 @@ types and utilities. Part of Gitoxide a pure Rust implementation of Git.")
("rust-gix-path" ,rust-gix-path-0.10)
("rust-gix-worktree" ,rust-gix-worktree-0.28)
("rust-io-close" ,rust-io-close-0.3)
- ("rust-thiserror" ,rust-thiserror-1))))
- (home-page "https://github.com/Byron/gitoxide")
- (synopsis
- "Gitoxide project functions that set Git's worktree to a particular state")
- (description
- "This package provides functions for setting the Git worktree to a particular
-state. Used by Gitoxide a pure Rust implementation of Git.")
- (license (list license:expat license:asl2.0))))
+ ("rust-thiserror" ,rust-thiserror-1))))))
(define-public rust-gix-worktree-state-0.4
(package