aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-07-27 16:31:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:22 +0200
commitc013502e7f24170e2f84ef6179ad98fc4f473ad9 (patch)
tree1e38ddf12eba1950d6d425aee184ba40d512bab5 /gnu/packages/crates-io.scm
parentd6a49479c1ce0f3e332eb41490fb8f46056412e1 (diff)
downloadguix-c013502e7f24170e2f84ef6179ad98fc4f473ad9.tar.gz
guix-c013502e7f24170e2f84ef6179ad98fc4f473ad9.zip
gnu: Add rust-indextree-4.
* gnu/packages/crates-io.scm (rust-indextree-4): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I890d898a9ffc454d31677d9de23d944bf2615bb9
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 12cb5d3764..0ea78d50b1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35971,6 +35971,28 @@ or numerical index. A corresponding hash set type is also provided.")
("rust-rand" ,rust-rand-0.7)
("rust-serde-derive" ,rust-serde-derive-1))))))
+(define-public rust-indextree-4
+ (package
+ (name "rust-indextree")
+ (version "4.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "indextree" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dnysxws5kpw8c3yvnhq3r9p2kfqqrgcw29x7hrg2gn6wp812164"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-rayon" ,rust-rayon-1)
+ ("rust-serde" ,rust-serde-1))))
+ (home-page "https://github.com/saschagrunert/indextree")
+ (synopsis "Arena based tree structure by using indices")
+ (description
+ "This package provides arena based tree structure by using indices instead
+of reference counted pointers.")
+ (license license:expat)))
+
(define-public rust-indicatif-0.16
(package
(name "rust-indicatif")