aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-03 09:55:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:04 +0300
commit533779c2354712270f69b5628074e607043effaa (patch)
tree9d77edfb59145680940234a3d879e32581b0a966 /gnu/packages/crates-io.scm
parent53f5f8b49e190f81cd2a1abf835efdee443f2b3b (diff)
downloadguix-533779c2354712270f69b5628074e607043effaa.tar.gz
guix-533779c2354712270f69b5628074e607043effaa.zip
gnu: Add rust-repr-offset-0.2.
* gnu/packages/crates-io.scm (rust-repr-offset-0.2, rust-repr-offset-derive-0.2): New variables.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 29cdd7bd68..d0a0ee4072 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55222,6 +55222,57 @@ Rust.")
(description "File reopening utility.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-repr-offset-0.2
+ (package
+ (name "rust-repr-offset")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "repr-offset" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1skj3cy77j7vwslnjjzgladq61z6jjvwlw89kp0zz7fjbdsp047v"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; tests must be run with the "testing" feature
+ #:cargo-inputs
+ (("rust-repr-offset-derive" ,rust-repr-offset-derive-0.2)
+ ("rust-tstr" ,rust-tstr-0.2))
+ #:cargo-development-inputs
+ (("rust-repr-offset-derive" ,rust-repr-offset-derive-0.2))))
+ (home-page "https://github.com/rodrimati1992/repr_offset_crates/")
+ (synopsis "Offsets of fields for types with a stable layout")
+ (description "Offsets of fields for types with a stable layout.")
+ (license license:zlib)))
+
+(define-public rust-repr-offset-derive-0.2
+ (package
+ (name "rust-repr-offset-derive")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "repr-offset-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1rwkbf12vmgi5v1llmgiirn0yaaiyw821rd7fc9fhpbkdxz95yh9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; tests must be run with the "testing" feature
+ #:cargo-inputs
+ (("rust-as-derive-utils" ,rust-as-derive-utils-0.8)
+ ("rust-core-extensions" ,rust-core-extensions-0.1)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://github.com/rodrimati1992/repr_offset_crates/")
+ (synopsis
+ "For deriving the offsets of fields for types with a stable layout")
+ (description
+ "For deriving the offsets of fields for types with a stable layout.")
+ (license license:zlib)))
+
(define-public rust-reqwest-0.11
(package
(name "rust-reqwest")