aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-gtk.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-11-06 21:41:23 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:09 +0200
commit35eaec019ed0a53a6e091d2b6df4867ede56287a (patch)
treeec4b42b2254aa0f9bbbc35fd0bfa375ad1b8c6cd /gnu/packages/crates-gtk.scm
parent10eccd8b0389faaa0b4a957cfc356a7f53b70517 (diff)
downloadguix-35eaec019ed0a53a6e091d2b6df4867ede56287a.tar.gz
guix-35eaec019ed0a53a6e091d2b6df4867ede56287a.zip
gnu: Add rust-gdk4-sys-0.8.
* gnu/packages/crates-gtk.scm (rust-gdk4-sys-0.8): New variable. (rust-gdk4-sys-0.7): Inherit from rust-gdk4-sys-0.8. Change-Id: If4c314effafb342df87b1260a5c61c15d1f10b29
Diffstat (limited to 'gnu/packages/crates-gtk.scm')
-rw-r--r--gnu/packages/crates-gtk.scm41
1 files changed, 33 insertions, 8 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index a29ae47c89..510268d2e6 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1143,8 +1143,40 @@
(description "This package provides rust bindings of the GDK 4 library.")
(license license:expat)))
+(define-public rust-gdk4-sys-0.8
+ (package
+ (name "rust-gdk4-sys")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gdk4-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1pb6vklx9ik7jx9cmrw2vywlx9ssqhll8q77ky8p8w56x2s8yhf9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-cairo-sys-rs" ,rust-cairo-sys-rs-0.19)
+ ("rust-gdk-pixbuf-sys" ,rust-gdk-pixbuf-sys-0.19)
+ ("rust-gio-sys" ,rust-gio-sys-0.19)
+ ("rust-glib-sys" ,rust-glib-sys-0.19)
+ ("rust-gobject-sys" ,rust-gobject-sys-0.19)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-pango-sys" ,rust-pango-sys-0.19)
+ ("rust-pkg-config" ,rust-pkg-config-0.3)
+ ("rust-system-deps" ,rust-system-deps-6))
+ #:cargo-development-inputs (("rust-shell-words" ,rust-shell-words-1)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (native-inputs (list pkg-config))
+ (inputs (list cairo gdk-pixbuf glib gtk pango))
+ (home-page "https://gtk-rs.org/")
+ (synopsis "FFI bindings of GDK 4")
+ (description "This package provides FFI bindings of GDK 4.")
+ (license license:expat)))
+
(define-public rust-gdk4-sys-0.7
(package
+ (inherit rust-gdk4-sys-0.8)
(name "rust-gdk4-sys")
(version "0.7.2")
(source
@@ -1154,7 +1186,6 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1w7yvir565sjrrw828lss07749hfpfsr19jdjzwivkx36brl7ayv"))))
- (build-system cargo-build-system)
(arguments
`(#:tests? #f ; ‘GDK_MEMORY_A16’ undeclared
#:cargo-inputs (("rust-cairo-sys-rs" ,rust-cairo-sys-rs-0.18)
@@ -1167,13 +1198,7 @@
("rust-pkg-config" ,rust-pkg-config-0.3)
("rust-system-deps" ,rust-system-deps-6))
#:cargo-development-inputs (("rust-shell-words" ,rust-shell-words-1)
- ("rust-tempfile" ,rust-tempfile-3))))
- (native-inputs (list pkg-config))
- (inputs (list cairo gdk-pixbuf glib gtk pango))
- (home-page "https://gtk-rs.org/")
- (synopsis "FFI bindings of GDK 4")
- (description "This package provides FFI bindings of GDK 4.")
- (license license:expat)))
+ ("rust-tempfile" ,rust-tempfile-3))))))
(define-public rust-gio-0.20
(package