aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-14 10:29:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:22 +0200
commit88706ebade07486dd6c91aa66f6cc42cde5ef292 (patch)
treedd4a0a2e6d355547dd2fda42fc515d9b980cdae3 /gnu/packages/crates-graphics.scm
parentd546b85bd666b2e75c7a3ba7f88bc5bb3be24f95 (diff)
downloadguix-88706ebade07486dd6c91aa66f6cc42cde5ef292.tar.gz
guix-88706ebade07486dd6c91aa66f6cc42cde5ef292.zip
gnu: Add rust-wayland-protocols-plasma-0.3.
* gnu/packages/crates-graphics.scm (rust-wayland-protocols-plasma-0.3): New variable. (rust-wayland-protocols-plasma-0.2): Inherit from rust-wayland-protocols-plasma-0.3. Change-Id: I2b772bed0ce7ed8bd068a77162bad43a36d35b2f
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm31
1 files changed, 26 insertions, 5 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 50b6aa41c8..4bacb12939 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -5036,30 +5036,51 @@ extensions.")
("rust-wayland-sys" ,rust-wayland-sys-0.21)
("rust-wayland-scanner" ,rust-wayland-scanner-0.21))))))
-(define-public rust-wayland-protocols-plasma-0.2
+(define-public rust-wayland-protocols-plasma-0.3
(package
(name "rust-wayland-protocols-plasma")
- (version "0.2.0")
+ (version "0.3.5")
(source
(origin
(method url-fetch)
(uri (crate-uri "wayland-protocols-plasma" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0yglbxd4ka8284k0j0ssh9hf6wd9qp2n0s2qrsdymyaz258kb013"))))
+ (base32 "1g8jxv1k3zdbcqmhr4fpghgibp2940hz45sm2pmwfs7f92swlccv"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-2)
("rust-wayland-backend" ,rust-wayland-backend-0.3)
("rust-wayland-client" ,rust-wayland-client-0.31)
- ("rust-wayland-protocols" ,rust-wayland-protocols-0.31)
+ ("rust-wayland-protocols" ,rust-wayland-protocols-0.32)
("rust-wayland-scanner" ,rust-wayland-scanner-0.31)
("rust-wayland-server" ,rust-wayland-server-0.31))))
(home-page "https://github.com/smithay/wayland-rs")
(synopsis "Generated API for the Plasma wayland protocol extensions")
- (description "Generated API for the Plasma wayland protocol extensions.")
+ (description "This package provides a generated API for the Plasma wayland
+protocol extensions.")
(license license:expat)))
+(define-public rust-wayland-protocols-plasma-0.2
+ (package
+ (inherit rust-wayland-protocols-plasma-0.3)
+ (name "rust-wayland-protocols-plasma")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wayland-protocols-plasma" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0yglbxd4ka8284k0j0ssh9hf6wd9qp2n0s2qrsdymyaz258kb013"))))
+ (arguments
+ `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-2)
+ ("rust-wayland-backend" ,rust-wayland-backend-0.3)
+ ("rust-wayland-client" ,rust-wayland-client-0.31)
+ ("rust-wayland-protocols" ,rust-wayland-protocols-0.31)
+ ("rust-wayland-scanner" ,rust-wayland-scanner-0.31)
+ ("rust-wayland-server" ,rust-wayland-server-0.31))))))
+
(define-public rust-wayland-protocols-wlr-0.2
(package
(name "rust-wayland-protocols-wlr")