aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-14 10:30:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:22 +0200
commit3b572d099103377b3cbd8a6f02e91f12f34c7d20 (patch)
tree9a7e0d8df283ecdd1daa7e547085783d2dfb7556 /gnu/packages/crates-graphics.scm
parent9418a280425a1b3866da1897e18e8628c400caeb (diff)
downloadguix-3b572d099103377b3cbd8a6f02e91f12f34c7d20.tar.gz
guix-3b572d099103377b3cbd8a6f02e91f12f34c7d20.zip
gnu: Add rust-webp-0.3.
* gnu/packages/crates-graphics.scm (rust-webp-0.3): New variable. (rust-webp-0.2): Inherit from rust-webp-0.3. Change-Id: Iebc68302db89ab227618b5bc7f6efff8a831afeb
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 1e0a5d614a..8db05e1244 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -5677,8 +5677,32 @@ with wayrs-client.")
from xml files.")
(license license:expat)))
+(define-public rust-webp-0.3
+ (package
+ (name "rust-webp")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "webp" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "169dihaimcr3ih3fqg8z3n47aqd9rhb3vhw4hk0g0npva4pialwg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; Test fails to find all webp functions.
+ #:cargo-inputs (("rust-image" ,rust-image-0.25)
+ ("rust-libwebp-sys" ,rust-libwebp-sys-0.9))
+ #:cargo-development-inputs (("rust-image" ,rust-image-0.25))))
+ (inputs (list libwebp))
+ (home-page "https://github.com/jaredforth/webp")
+ (synopsis "WebP conversion library")
+ (description "This package provides a @code{WebP} conversion library.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-webp-0.2
(package
+ (inherit rust-webp-0.3)
(name "rust-webp")
(version "0.2.2")
(source (origin
@@ -5687,17 +5711,12 @@ from xml files.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1bhw6xp7vg4rx7flxgzvdzk21q2dx1bsn06h0yj7jq0n3y12y0ng"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-image" ,rust-image-0.24)
("rust-libwebp-sys" ,rust-libwebp-sys-0.4))
#:cargo-development-inputs
- (("rust-image" ,rust-image-0.24))))
- (home-page "https://github.com/jaredforth/webp")
- (synopsis "WebP conversion library")
- (description "This package procides a WebP conversion library.")
- (license (list license:expat license:asl2.0))))
+ (("rust-image" ,rust-image-0.24))))))
(define-public rust-winit-0.29
(package