aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-14 09:49:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:15 +0200
commit175b6e2e0fb4dcaf70181646430da403c004a100 (patch)
tree92cc6bd1de5c13d2059c9474ae3e006386ecf61b /gnu/packages/crates-graphics.scm
parentef4a797d4287f5ab58dd506dcceb4071d80487c1 (diff)
downloadguix-175b6e2e0fb4dcaf70181646430da403c004a100.tar.gz
guix-175b6e2e0fb4dcaf70181646430da403c004a100.zip
gnu: Add rust-glutin-glx-sys-0.6.
* gnu/packages/crates-graphics.scm (rust-glutin-glx-sys-0.6): New variable. (rust-glutin-glx-sys-0.5): Inherit from rust-glutin-glx-sys-0.6. Change-Id: I1942c1bab73f98c8e25dd89eadcefac19a767cca
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm24
1 files changed, 20 insertions, 4 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index ecc634c3d0..430eabadbf 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2046,26 +2046,42 @@ EUI-64, also known as MAC-48 media access control addresses.")
(description "This package provides gles2 bindings for glutin.")
(license license:asl2.0)))
-(define-public rust-glutin-glx-sys-0.5
+(define-public rust-glutin-glx-sys-0.6
(package
(name "rust-glutin-glx-sys")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "glutin_glx_sys" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0krv3chf5sy83rsfwq267paczskpwnb5gcw0agac5p0hdilgsrd1"))))
+ (base32 "0qscs9525kpdwaky5cm6smkyrrlg9sv5xdcnhzh1hvp730wjsaww"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-gl-generator" ,rust-gl-generator-0.14)
("rust-x11-dl" ,rust-x11-dl-2))))
(home-page "https://github.com/rust-windowing/glutin")
(synopsis "Glx bindings for glutin")
- (description "This package provides glx bindings for glutin.")
+ (description "This package provides the glx bindings for glutin.")
(license license:asl2.0)))
+(define-public rust-glutin-glx-sys-0.5
+ (package
+ (inherit rust-glutin-glx-sys-0.6)
+ (name "rust-glutin-glx-sys")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "glutin_glx_sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0krv3chf5sy83rsfwq267paczskpwnb5gcw0agac5p0hdilgsrd1"))))
+ (arguments
+ `(#:cargo-inputs (("rust-gl-generator" ,rust-gl-generator-0.14)
+ ("rust-x11-dl" ,rust-x11-dl-2))))))
+
(define-public rust-glutin-glx-sys-0.4
(package
(inherit rust-glutin-glx-sys-0.5)
ce): ... this. * gnu/services/desktop.scm (upower-dmd-service, elogind-dmd-service): Rename to... (upower-shepherd-service, elogind-shepherd-service): ... this. * gnu/services/dbus.scm (dbus-dmd-service): Rename to... (dbus-shepherd-service): ... this. * gnu/services/lirc.scm (lirc-dmd-service): Rename to... (lirc-shepherd-service): ... this. * gnu/services/mail.scm (dovecot-dmd-service): Rename to... (dovecot-shepherd-service): ... this. * gnu/services/networking.scm (ntp-dmd-service, tor-dmd-service) (bitlbee-dmd-service, wicd-dmd-service, network-manager-dmd-service): Rename to... (dbus-shepherd-service): ... this. * gnu/services/ssh.scm (lsh-dmd-service): Rename to... (lsh-shepherd-service): ... this. * gnu/services/web.scm (nginx-dmd-service): Rename to... (nginx-shepherd-service): ... this. * gnu/services/xorg.scm (slim-dmd-service): Rename to... (slim-shepherd-service): ... this. * gnu/system.scm (essential-services): Use '%shepherd-root-service'. * gnu/system/install.scm (cow-store-service-type): Adjust accordingly. * guix/scripts/system.scm (dmd-service-node-label, dmd-service-node-type) (export-dmd-graph): Likewise. * tests/guix-system.sh: Likewise. * tests/services.scm ("dmd-service-back-edges"): Rename to... ("shepherd-service-back-edges"): Adjust accordingly. * doc/guix.texi: Likewise. * doc/images/service-graph.dot: Use 'shepherd' service name. Alex Kost 2016-01-12doc: Show bootstrapping at the package level....* doc/images/bootstrap-packages.dot: New file. * doc.am (DOT_FILES): Add it. * doc/guix.texi (Bootstrapping): Show 'guix graph' commands. Includes 'images/bootstrap-packages' and comment it. Ludovic Courtès 2015-11-02services: Add 'profile-service-type'....* gnu/services.scm (packages->profile-entry): New procedure. (profile-service-type): New variable. * gnu/system.scm (operating-system-directory-base-entries): Remove the "profile" entry. (essential-services): Add a PROFILE-SERVICE-TYPE instance. (operating-system-profile): Rewrite in terms of 'fold-services'. * doc/guix.texi (Service Reference): Add 'profile-service-type'. * doc/images/service-graph.dot: Likewise. Ludovic Courtès 2015-11-02services: Add 'system-service-type'....* gnu/services.scm (system-derivation): New procedure. (system-service-type): New variable. (boot-script-entry): New procedure. (boot-service-type): Extend SYSTEM-SERVICE-TYPE. (etc-entry): New procedure. (etc-service-type): Extend SYSTEM-SERVICE-TYPE. (fold-services): Change default #:target-type to SYSTEM-SERVICE-TYPE. * gnu/system.scm (operating-system-directory-base-entries): New procedure. (essential-services): Use it. Add an instance of SYSTEM-SERVICE-TYPE. (operating-system-boot-script): Pass #:target-type to 'fold-services'. (operating-system-derivation): Rewrite in terms of 'fold-services'. * gnu/system/linux-container.scm (system-container): Remove. (container-script): Use 'operating-system-derivation'. * guix/scripts/system.scm (export-extension-graph): Replace BOOT-SERVICE-TYPE by SYSTEM-SERVICE-TYPE. * doc/images/service-graph.dot: Add 'system' node and edges. * doc/guix.texi (Service Composition): Mention SYSTEM-SERVICE-TYPE. (Service Reference): Document it. Update 'fold-services' documentation. Ludovic Courtès