aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:02:31 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:40:53 +0300
commit5006b11965d1216f61e613379e8a2f26e6d0facd (patch)
tree46e2487d8dadcdc0c70c74d268d994366b7dbdab /gnu/packages/crates-crypto.scm
parent630bd06b05a0a49a467bdfe9988feb4c32741f15 (diff)
downloadguix-5006b11965d1216f61e613379e8a2f26e6d0facd.tar.gz
guix-5006b11965d1216f61e613379e8a2f26e6d0facd.zip
gnu: Add rust-k256-0.13.
* gnu/packages/crates-crypto.scm (rust-k256-0.13): Add variable. Change-Id: I674837d219efcb665b3733104df7ddbaeecf56dd Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index d4205f7d70..9e3773649c 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2023 Steve George <steve@futurile.net>
;;; Copyright © 2023 VÖRÖSKŐI András <voroskoi@gmail.com>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2520,6 +2521,48 @@ Hash-based Message Authentication Code}.")
Hash-based Message Authentication Code algorithm} for SHA1.")
(license license:bsd-3)))
+(define-public rust-k256-0.13
+ (package
+ (name "rust-k256")
+ (version "0.13.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "k256" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0ysq18pjz040am5llgly90464x7qqq98yxfbcsladq96gsvgjvwm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-ecdsa" ,rust-ecdsa-0.16)
+ ("rust-elliptic-curve" ,rust-elliptic-curve-0.13)
+ ("rust-hex-literal" ,rust-hex-literal-0.4)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-serdect" ,rust-serdect-0.2)
+ ("rust-sha2" ,rust-sha2-0.10)
+ ("rust-signature" ,rust-signature-2))
+ #:cargo-development-inputs (("rust-blobby" ,rust-blobby-0.3)
+ ("rust-criterion" ,rust-criterion-0.5)
+ ("rust-ecdsa" ,rust-ecdsa-0.16)
+ ("rust-hex-literal" ,rust-hex-literal-0.4)
+ ("rust-num-bigint" ,rust-num-bigint-0.4)
+ ("rust-num-traits" ,rust-num-traits-0.2)
+ ("rust-proptest" ,rust-proptest-1)
+ ("rust-rand-core" ,rust-rand-core-0.6)
+ ("rust-sha3" ,rust-sha3-0.10))))
+ (home-page
+ "https://github.com/RustCrypto/elliptic-curves/tree/master/k256")
+ (synopsis
+ "Library supporting general-purpose elliptic curve group operations")
+ (description
+ "This package provides a secp256k1 elliptic curve library written in pure
+Rust with support for ECDSA signing/verification/public-key recovery,
+@dfn{Taproot Schnorr signatures} (BIP340), @dfn{Elliptic Curve Diffie-Hellman}
+(ECDH), and general-purpose secp256k1 elliptic curve group operations which can
+be used to implement arbitrary protocols.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-kuznyechik-0.8
(package
(name "rust-kuznyechik")