aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-18 12:01:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:43:20 +0300
commit33e7795243c466bb31426a94f039e9577eaee0f4 (patch)
tree2d7fc2c17f23fa61623e8403138a377c7c2ad927 /gnu/packages/crates-crypto.scm
parent66482d599c79fbb2664011b53ac1c959a8d0cc99 (diff)
downloadguix-33e7795243c466bb31426a94f039e9577eaee0f4.tar.gz
guix-33e7795243c466bb31426a94f039e9577eaee0f4.zip
gnu: Add rust-chacha20-0.7.
* gnu/packages/crates-crypto.scm (rust-chacha20-0.7): New variable. Change-Id: Iae3768dd2b82f67aca148d034d0971aa362d13f6
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 671be641ec..4af2184d52 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1169,6 +1169,32 @@ XChaCha20, XChaCha12 and XChaCha8 stream ciphers, and also optional
(("rust-cipher" ,rust-cipher-0.3)
("rust-hex-literal" ,rust-hex-literal-0.2))))))
+(define-public rust-chacha20-0.7
+ (package
+ (inherit rust-chacha20-0.9)
+ (name "rust-chacha20")
+ (version "0.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "chacha20" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1c8h4sp9zh13v8p9arydjcj92xc6j3mccrjc4mizrvq7fzx9717h"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "Cargo.toml"
+ (("version = \">=1, <1.4\"") "version = \"^1\""))))))
+ (arguments
+ `(#:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-cipher" ,rust-cipher-0.3)
+ ("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-rand-core" ,rust-rand-core-0.6)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-cipher" ,rust-cipher-0.3)
+ ("rust-hex-literal" ,rust-hex-literal-0.2))))))
+
(define-public rust-chacha20poly1305-0.10
(package
(name "rust-chacha20poly1305")