aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:07:58 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:42:31 +0300
commit03139fe8a5db5325689fc6debcd82b4726edf047 (patch)
treeef1bd9574de8922873b2977a0fbd017ee2d349a5 /gnu/packages/crates-crypto.scm
parentb15631302227f989b9d3f8144b24fd6160697cb3 (diff)
downloadguix-03139fe8a5db5325689fc6debcd82b4726edf047.tar.gz
guix-03139fe8a5db5325689fc6debcd82b4726edf047.zip
gnu: Add rust-chacha20poly1305-0.10.
* gnu/packages/crates-crypto.scm (rust-chacha20poly1305-0.10): Add variable. (rust-chacha20poly1305-0.9): Inherit from rust-chacha20poly1305-0.10. Change-Id: I8e3d9270bb06baa051bb9eff8a7a507c5ac4a9ad Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm43
1 files changed, 31 insertions, 12 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 410d0b5d89..57051c80c9 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1169,8 +1169,38 @@ XChaCha20, XChaCha12 and XChaCha8 stream ciphers, and also optional
(("rust-cipher" ,rust-cipher-0.3)
("rust-hex-literal" ,rust-hex-literal-0.2))))))
+(define-public rust-chacha20poly1305-0.10
+ (package
+ (name "rust-chacha20poly1305")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "chacha20poly1305" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0dfwq9ag7x7lnd0znafpcn8h7k4nfr9gkzm0w7sc1lcj451pkk8h"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-aead" ,rust-aead-0.5)
+ ("rust-chacha20" ,rust-chacha20-0.9)
+ ("rust-cipher" ,rust-cipher-0.4)
+ ("rust-poly1305" ,rust-poly1305-0.8)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-aead" ,rust-aead-0.5))))
+ (home-page "https://github.com/RustCrypto/AEADs/tree/master/chacha20poly1305")
+ (synopsis "Rust implementation of ChaCha20Poly1305 Authenticated Encryption")
+ (description
+ "Pure Rust implementation of the ChaCha20Poly1305 Authenticated Encryption
+with Additional Data Cipher (RFC 8439) with optional architecture-specific
+hardware acceleration. Also contains implementations of the XChaCha20Poly1305
+extended nonce variant of ChaCha20Poly1305, and the reduced-round
+ChaCha8Poly1305 and ChaCha12Poly1305 lightweight variants.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-chacha20poly1305-0.9
(package
+ (inherit rust-chacha20poly1305-0.10)
(name "rust-chacha20poly1305")
(version "0.9.1")
(source
@@ -1185,7 +1215,6 @@ XChaCha20, XChaCha12 and XChaCha8 stream ciphers, and also optional
'(begin
(substitute* "Cargo.toml"
(("version = \">=1, <1.5\"") "version = \"^1\""))))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-aead" ,rust-aead-0.4)
@@ -1194,17 +1223,7 @@ XChaCha20, XChaCha12 and XChaCha8 stream ciphers, and also optional
("rust-poly1305" ,rust-poly1305-0.7)
("rust-zeroize" ,rust-zeroize-1))
#:cargo-development-inputs
- (("rust-aead" ,rust-aead-0.4))))
- (home-page "https://github.com/RustCrypto/AEADs/tree/master/chacha20poly1305")
- (synopsis
- "Pure Rust implementation of ChaCha20Poly1305 Authenticated Encryption")
- (description
- "Pure Rust implementation of the ChaCha20Poly1305 Authenticated
-Encryption with Additional Data Cipher (RFC 8439) with optional
-architecture-specific hardware acceleration. Also contains implementations of
-the XChaCha20Poly1305 extended nonce variant of ChaCha20Poly1305, and the
-reduced-round ChaCha8Poly1305 and ChaCha12Poly1305 lightweight variants.")
- (license (list license:asl2.0 license:expat))))
+ (("rust-aead" ,rust-aead-0.4))))))
(define-public rust-cipher-0.4
(package