aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-27 10:29:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-03 16:59:53 +0100
commitefed932ad99f3076c79c35b966b49a87abd6adfc (patch)
tree98c46232ab8e66d2fd05ca846d4e20efcf0a9cb4 /gnu/packages/cran.scm
parentb0e687ae7d20ade86f1f44813a934f9f441921fa (diff)
downloadguix-efed932ad99f3076c79c35b966b49a87abd6adfc.tar.gz
guix-efed932ad99f3076c79c35b966b49a87abd6adfc.zip
gnu: Add r-plotmo.
* gnu/packages/cran.scm (r-plotmo): New variable. Change-Id: Id0803e02acc72f1f98429f023b1d673453fde302
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 66a8a88105..294b5d417b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4406,6 +4406,29 @@ does not use formula input or special syntax, but can be used in combination
with default R plot functions.")
(license license:gpl2+)))
+(define-public r-plotmo
+ (package
+ (name "r-plotmo")
+ (version "3.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "plotmo" version))
+ (sha256
+ (base32 "0wl2xlidib4r54nm1q5zndr9iilagpyc3xlxs0cpd487hdh3zcn8"))))
+ (properties `((upstream-name . "plotmo")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-formula r-plotrix))
+ (native-inputs (list r-rpart))
+ (home-page "http://www.milbo.users.sonic.net")
+ (synopsis
+ "Plot a model's residuals, response, and partial dependence plots")
+ (description
+ "This package lets you plot model surfaces for a wide variety of models
+using partial dependence plots and other techniques. Also plot model
+residuals and other information on the model.")
+ (license license:gpl3)))
+
(define-public r-plumber
(package
(name "r-plumber")