aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-26 18:02:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-03 16:59:49 +0100
commited6e2124f0944999e0ac8abf89daaaf86dac4a7f (patch)
treeb64c3f43f510f1e1e82ecdab85e791e0a667d166 /gnu/packages/cran.scm
parent32ec8e8e18332414d73b61cf2a41cb47dbb0f103 (diff)
downloadguix-ed6e2124f0944999e0ac8abf89daaaf86dac4a7f.tar.gz
guix-ed6e2124f0944999e0ac8abf89daaaf86dac4a7f.zip
gnu: Add r-dcurver.
* gnu/packages/cran.scm (r-dcurver): New variable. Change-Id: I8ab58dc4258bb786f00a2a9e7f0a5cdf336ddcb6
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2db95ab73d..c9d0ef0557 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37116,6 +37116,32 @@ Analysis and Modelling, including Exploratory Spatio-Temporal Analysis and
Inferred Spatio-Temporal Modelling.")
(license license:gpl2+)))
+(define-public r-dcurver
+ (package
+ (name "r-dcurver")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dcurver" version))
+ (sha256
+ (base32 "1v4h480lff1cyjjwb80dksiffh0y4b3s07lq2l2r21rn1l4mav6c"))))
+ (properties `((upstream-name . "dcurver")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp r-rcpparmadillo))
+ (native-inputs (list r-testthat))
+ (home-page "https://github.com/oguzhanogreden/dcurver")
+ (synopsis "Utility functions for Davidian curves")
+ (description
+ "This package provides a Davidian curve defines a seminonparametric density,
+whose shape and flexibility can be tuned by easy to estimate parameters. Since
+a special case of a Davidian curve is the standard normal density, Davidian
+curves can be used for relaxing normality assumption in statistical applications
+(Zhang & Davidian, 2001) <doi:10.1111/j.0006-341X.2001.00795.x>. This package
+provides the density function, the gradient of the loglikelihood and a random
+generator for Davidian curves.")
+ (license license:gpl3)))
+
(define-public r-dcv
(package
(name "r-dcv")