aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-04 16:25:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-04 16:25:20 +0100
commite00ca95e08bc1cc2cb39f3178485ef16defce0be (patch)
tree2ef4f30380d0e203553cb68d597c5fb8d1fe69ce /gnu/packages/cran.scm
parent3cfd6e11a4bd4ee12f508ea5dabc59b81e876ea0 (diff)
downloadguix-e00ca95e08bc1cc2cb39f3178485ef16defce0be.tar.gz
guix-e00ca95e08bc1cc2cb39f3178485ef16defce0be.zip
gnu: Add r-ggupset.
* gnu/packages/cran.scm (r-ggupset): New variable. Change-Id: I044fff58b66dbb56e6b7fb1ebcb5353e7ab3d1f7
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 298704185c..72e751c4af 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1635,6 +1635,30 @@ robust, and Bayesian versions of t-test/ANOVA, correlation analyses,
contingency table analysis, meta-analysis, and regression analyses.")
(license license:gpl3)))
+(define-public r-ggupset
+ (package
+ (name "r-ggupset")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggupset" version))
+ (sha256
+ (base32 "0cycnnycn1qazy35s4w746zlfraayf109bq40fglklmick6kfwsz"))))
+ (properties `((upstream-name . "ggupset")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-gtable r-rlang r-scales r-tibble))
+ (native-inputs (list r-testthat))
+ (home-page "https://github.com/const-ae/ggupset")
+ (synopsis "Combination matrix axis for ggplot2 to create UpSet plots")
+ (description
+ "This package lets you replace the standard x-axis in ggplots with a
+combination matrix to visualize complex set overlaps. UpSet has introduced a
+new way to visualize the overlap of sets as an alternative to Venn diagrams.
+This package provides a simple way to produce such plots using ggplot2. In
+addition it can convert any categorical axis into a combination matrix axis.")
+ (license license:gpl3)))
+
(define-public r-glmpca
(package
(name "r-glmpca")