aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-26 17:59:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-03 16:59:49 +0100
commitc8529fc172b740f434559a12590eff5208e4cbb6 (patch)
treedac262d48037a89ca3acb5eeb86a5049387d7f34 /gnu/packages/cran.scm
parent0f501b0be6b56443bc1c4be0430e94ebd0e3cb28 (diff)
downloadguix-c8529fc172b740f434559a12590eff5208e4cbb6.tar.gz
guix-c8529fc172b740f434559a12590eff5208e4cbb6.zip
gnu: Add r-beepr.
* gnu/packages/cran.scm (r-beepr): New variable. Change-Id: I57c31192998960f915f405bc82f66413e650f7aa
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b549d8333c..fedef4cb09 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -241,6 +241,29 @@ a recent compiler). Asio is written and maintained by Christopher
M. Kohlhoff, and released under the Boost Software License', Version 1.0.")
(license license:boost1.0)))
+(define-public r-beepr
+ (package
+ (name "r-beepr")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "beepr" version))
+ (sha256
+ (base32 "0xq4qs06f61m1q6gb157n4c3j7pf7wanh27nr2lr228s7k4mw3k2"))))
+ (properties `((upstream-name . "beepr")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-audio))
+ (native-inputs (list r-testthat))
+ (home-page "https://github.com/rasmusab/beepr")
+ (synopsis "Easily play notification sounds on any platform")
+ (description
+ "The main function of this package is @code{beep()}, with the purpose to
+make it easy to play notification sounds on whatever platform you are on. It
+is intended to be useful, for example, if you are running a long analysis in
+the background and want to know when it is ready.")
+ (license license:gpl3)))
+
(define-public r-betareg
(package
(name "r-betareg")