aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-26 18:05:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-03 16:59:50 +0100
commit1bfe1a206f1c43b99540fd8d970fb9a9f2caf67f (patch)
treecaefb24913e931bbee0d3a8b6ad500ba55ec75c4 /gnu/packages/cran.scm
parent16632b6cdbb4258da8cdabd4097147abb5f09d6e (diff)
downloadguix-1bfe1a206f1c43b99540fd8d970fb9a9f2caf67f.tar.gz
guix-1bfe1a206f1c43b99540fd8d970fb9a9f2caf67f.zip
gnu: Add r-greg.
* gnu/packages/cran.scm (r-greg): New variable. Change-Id: I67b2f7384a7927f8f985c9aee558af7d1b0edc24
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ae5c31c18e..94e71ae184 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4669,6 +4669,52 @@ regions. GAs can be run sequentially or in parallel, using an explicit
master-slave parallelisation or a coarse-grain islands approach.")
(license license:gpl2+)))
+(define-public r-greg
+ (package
+ (name "r-greg")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Greg" version))
+ (sha256
+ (base32 "13rsah8vf9s8wpkr5hlayyqa8v728cz80bvpg8vmlvnam8isb30s"))))
+ (properties `((upstream-name . "Greg")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-broom
+ r-dplyr
+ r-epi
+ r-forestplot
+ r-glue
+ r-gmisc
+ r-hmisc
+ r-htmltable
+ r-knitr
+ r-nlme
+ r-purrr
+ r-rlang
+ r-rms
+ r-sandwich
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-tidyselect))
+ (native-inputs (list r-boot r-knitr r-testthat r-tidyverse))
+ (home-page "http://gforge.se")
+ (synopsis "Regression helper functions")
+ (description
+ "This package provides methods for manipulating regression models and for
+describing these in a style adapted for medical journals. It contains
+functions for generating an HTML table with crude and adjusted estimates,
+plotting hazard ratio, plotting model estimates and confidence intervals using
+forest plots, extending this to comparing multiple models in a single forest
+plots. In addition to the descriptive methods, there are functions for the
+robust covariance matrix provided by the sandwich package, a function for
+adding non-linearities to a model, and a wrapper around the Epi package's
+@code{Lexis()} functions for time-splitting a dataset when modeling
+non-proportional hazards in Cox regressions.")
+ (license license:gpl3+)))
+
(define-public r-grr
(package
(name "r-grr")