aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-26 20:56:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-03 16:59:51 +0100
commit0af4107d9f0f09d3023bbd2161dc7cf38441a40a (patch)
treec446c7d5496312c04d10dd77e9db4eedda605f42 /gnu/packages/cran.scm
parent527598ca24a669b82f7bac8fa896487036907868 (diff)
downloadguix-0af4107d9f0f09d3023bbd2161dc7cf38441a40a.tar.gz
guix-0af4107d9f0f09d3023bbd2161dc7cf38441a40a.zip
gnu: r-arrow: Add missing input.
* gnu/packages/cran.scm (r-arrow)[native-inputs]: Add glibc-utf8-locales, r-dplyr, r-hms, r-lubridate, r-stringr, r-tibble, and tzdata-for-tests. [arguments]: Add phases 'delete-bad-tests, 'set-test-locale, and 'set-timezone. Change-Id: Iece4e463ebe73d41a42594eff7850f2efa96b26f
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bf60fa4585..1a267d1a1e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29199,6 +29199,23 @@ colored by the number of neighboring points. This is useful to visualize the
"0pp7rllpmdwsx0idqhfg4lv96cvdj6pbnypnlrr835jqv7sxn502"))))
(properties `((upstream-name . "arrow")))
(build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'delete-bad-tests
+ (lambda _
+ ;; Two tests fail with "Cannot locate timezone"
+ (delete-file "tests/testthat/test-dataset-dplyr.R")))
+ ;; Some test fail when the current locale is the C locale.
+ (add-before 'check 'set-test-locale
+ (lambda _ (setenv "LC_ALL" "en_US.UTF-8")))
+ (add-before 'check 'set-timezone
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZ" "UTC+1")
+ (setenv "TZDIR"
+ (search-input-directory inputs
+ "share/zoneinfo")))))))
(inputs
(list `(,apache-arrow "lib") zlib))
(propagated-inputs
@@ -29212,7 +29229,15 @@ colored by the number of neighboring points. This is useful to visualize the
r-tidyselect
r-vctrs))
(native-inputs
- (list pkg-config r-testthat))
+ (list glibc-utf8-locales
+ pkg-config
+ r-dplyr
+ r-hms
+ r-lubridate
+ r-stringr
+ r-testthat
+ r-tibble
+ tzdata-for-tests))
(home-page "https://github.com/apache/arrow/")
(synopsis "R integration to Apache Arrow")
(description