gnu: dino: Add missing inputs.
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.
* gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
[inputs]: Add atk, cairo, gdk-pixbug+svg, libnice and pango.
0 files changed, 0 insertions, 0 deletions
ble-static")- #:phases (modify-phases %standard-phases
- (add-before 'configure 'pedantry
- (lambda _
- ;; XXX: libevdev includes kernel headers, which causes this
- ;; compile test to fail with:
- ;; ...-headers-4.14.67/include/asm-generic/posix_types.h:88:14:
- ;;error: ISO C90 does not support ‘long long’ [-Werror=long-long]
- (substitute* "test/Makefile.in"
- (("-pedantic -Werror -std=c89")
- "-pedantic -Werror -std=c99"))
- #t)))))
+ `(#:configure-flags '("--disable-static")))
(native-inputs `(("python" ,python)))
(home-page "https://www.freedesktop.org/wiki/Software/libevdev/")
(synopsis "Wrapper library for evdev devices")
@@ -4032,7 +4021,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.29")
+ (version "2.30")
(source
(origin
(method url-fetch)
@@ -4042,7 +4031,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "00hqc8nykvy8c09b8vab64dcd0ij3n5klxjn6rl00q7hickpah8x"))))
+ "1m4pnzlcdl6d1p7hdccpi0605zkikind00kjc5bx4gk3gd7m4nh9"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)
@@ -5461,19 +5450,10 @@ draggable titlebars and borders.")
;; This package is intended to be used when building GTK+.
;; Note: It's currently marked as "hidden" to avoid having two non-eq?
;; packages with the same name and version.
-;; TODO: Update this in the next rebuild cycle.
(define-public xorg-server-for-tests
(hidden-package
(package
- (inherit xorg-server)
- (version "1.20.7")
- (source (origin
- (inherit (package-source xorg-server))
- (uri (string-append "mirror://xorg/individual/xserver/"
- "xorg-server-" version ".tar.bz2"))
- (sha256
- (base32
- "18bfl04ihw1jr3h0fs522nnxxq5ixjay77y9dcymnkzk23q8cndx")))))))
+ (inherit xorg-server))))
(define-public xorg-server-xwayland
(package/inherit xorg-server