aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-18 22:53:09 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-18 23:19:21 +0200
commit6f450b87de18e6d41795848a8c3f4f6e749190c3 (patch)
tree2c2bbfdf343512bda9d47306fa4c09c044b4291c /gnu/packages/commencement.scm
parent1b2b81773c6931f4d01c448f04d021093da27d62 (diff)
downloadguix-6f450b87de18e6d41795848a8c3f4f6e749190c3.tar.gz
guix-6f450b87de18e6d41795848a8c3f4f6e749190c3.zip
gnu: gcc-toolchain: Remove 'bin/sh' and 'bin/bash'.
* gnu/packages/commencement.scm (gcc-toolchain)[arguments] <#:builder>: Delete 'bin/sh' and 'bin/bash'.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm24
1 files changed, 17 insertions, 7 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index da1b1ffd98..9611ff2620 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -756,16 +756,26 @@ COREUTILS-FINAL vs. COREUTILS, etc."
'(#:modules ((guix build union))
#:builder (begin
(use-modules (ice-9 match)
+ (srfi srfi-26)
(guix build union))
- (match %build-inputs
- (((names . directories) ...)
- (union-build (assoc-ref %outputs "out")
- directories)))
+ (let ((out (assoc-ref %outputs "out")))
- (union-build (assoc-ref %outputs "debug")
- (list (assoc-ref %build-inputs
- "libc-debug"))))))
+ (match %build-inputs
+ (((names . directories) ...)
+ (union-build out directories)))
+
+ ;; Remove the 'sh' and 'bash' binaries that come with
+ ;; libc to avoid polluting the user's profile (these are
+ ;; statically-linked binaries with no locale support and
+ ;; so on.)
+ (for-each (lambda (file)
+ (delete-file (string-append out "/bin/" file)))
+ '("sh" "bash"))
+
+ (union-build (assoc-ref %outputs "debug")
+ (list (assoc-ref %build-inputs
+ "libc-debug")))))))
(native-search-paths (package-native-search-paths gcc))
(search-paths (package-search-paths gcc))