aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-02-27 16:29:19 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-03-04 23:44:49 +0100
commit9e9e4686f76c17e4bc926377637d66626a63b9a0 (patch)
treec7ed59a42011a476990bfa98d711e1b26b2feaa0 /gnu/packages/chez.scm
parent61ca3d9a8483d91dd3a20d36d9e0c8081bd2fd2c (diff)
downloadguix-9e9e4686f76c17e4bc926377637d66626a63b9a0.tar.gz
guix-9e9e4686f76c17e4bc926377637d66626a63b9a0.zip
gnu: chez: Add 'chez-scheme-for-system'.
* gnu/packages/chez.scm (chez-scheme-for-system): New procedure. (chez-srfi, chez-web, chez-sockets, chez-matchable, chez-irregex) (chez-fmt, chez-mit, chez-scmutils): Use 'chez-scheme-for-system'. * gnu/packages/loko.scm (loko-scheme): Likewise. * gnu/packages/emacs-xyz.scm (emacs-geiser-chez): Likewise Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm33
1 files changed, 24 insertions, 9 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index e7ddab0d1f..b3aadf3a78 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -47,7 +47,8 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
- #:export (nix-system->chez-machine
+ #:export (chez-scheme-for-system
+ nix-system->chez-machine
chez-machine->nonthreaded
chez-machine->threaded
unpack-nanopass+stex))
@@ -67,6 +68,20 @@
;;
;; Code:
+(define* (chez-scheme-for-system #:optional
+ (system (or (%current-target-system)
+ (%current-system))))
+ "Return 'chez-scheme' unless only 'chez-scheme-for-racket' supports SYSTEM,
+including support for native threads."
+ (if (or
+ ;; full support upstream
+ (and=> (chez-upstream-features-for-system system)
+ (cut memq 'threads <>))
+ ;; no support anywhere
+ (not (nix-system->chez-machine system)))
+ chez-scheme
+ chez-scheme-for-racket))
+
(define (chez-machine->nonthreaded machine)
"Given a string MACHINE naming a Chez Scheme machine type, returns a string
naming the nonthreaded machine type for the same architecture and OS as
@@ -751,7 +766,7 @@ create compilers, making them easier to understand and maintain.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- (list chez-scheme))
+ (list (chez-scheme-for-system)))
(arguments
(list #:make-flags (chez-make-flags name version)
#:test-target "test"
@@ -782,7 +797,7 @@ create compilers, making them easier to understand and maintain.")
(base32 "1dq25qygyncbfq4kwwqqgyyakfqjwhp5q23vrf3bff1p66nyfl3b"))))
(build-system gnu-build-system)
(native-inputs
- (list chez-scheme
+ (list (chez-scheme-for-system)
ghostscript
;; FIXME: This package fails to build with the error:
;; mktexpk: don't know how to create bitmap font for bchr8r
@@ -847,7 +862,7 @@ programming in Scheme.")
(base32 "1n5fbwwz51fdzvjackgmnsgh363g9inyxv7kmzi0469cwavwcx5m"))))
(build-system gnu-build-system)
(native-inputs
- (list chez-scheme
+ (list (chez-scheme-for-system)
chez-web
(texlive-updmap.cfg (list texlive-pdftex))))
(arguments
@@ -933,7 +948,7 @@ Chez Scheme.")
(inputs
(list chez-srfi)) ; for tests
(native-inputs
- (list chez-scheme))
+ (list (chez-scheme-for-system)))
(arguments
(list #:make-flags (chez-make-flags name version)
#:test-target "test"
@@ -965,7 +980,7 @@ Chez Scheme.")
(propagated-inputs
(list chez-srfi)) ; for irregex-utils
(native-inputs
- (list chez-scheme))
+ (list (chez-scheme-for-system)))
(arguments
(list #:make-flags (chez-make-flags name version)
#:test-target "test"
@@ -996,7 +1011,7 @@ syntax, with various aliases for commonly used patterns.")
(propagated-inputs
(list chez-srfi)) ; for irregex-utils
(native-inputs
- (list chez-scheme))
+ (list (chez-scheme-for-system)))
(arguments
(list #:make-flags (chez-make-flags name version)
#:test-target "chez-check"
@@ -1059,7 +1074,7 @@ strings.")
(inputs
(list chez-srfi)) ; for tests
(native-inputs
- (list chez-scheme))
+ (list (chez-scheme-for-system)))
(arguments
(list #:make-flags (chez-make-flags name version)
#:test-target "test"
@@ -1090,7 +1105,7 @@ required to port the program @code{Scmutils} to Chez Scheme.")
(inputs
(list chez-srfi)) ; for tests
(native-inputs
- (list chez-scheme))
+ (list (chez-scheme-for-system)))
(propagated-inputs
(list chez-mit chez-srfi))
(arguments
* guix/packages.scm (<content-hash>): New record type. (define-content-hash-constructor, build-content-hash) (content-hash): New macros. (print-content-hash): New procedure. (<origin>): Rename constructor to '%origin'. [sha256]: Remove field. [hash]: New field. Adjust users. (origin-compatibility-helper, origin): New macros. (origin-sha256): New deprecated procedure. (origin->derivation): Adjust accordingly. * tests/packages.scm ("package-source-derivation, origin, sha512"): New test. * guix/tests.scm: Hide (gcrypt hash) 'sha256' for proper syntax matching. * tests/challenge.scm: Add #:prefix for (gcrypt hash) and adjust users. * tests/derivations.scm: Likewise. * tests/store.scm: Likewise. * tests/graph.scm ("bag DAG, including origins"): Provide 'sha256' field with the right length. * gnu/packages/aspell.scm (aspell-dictionary) (aspell-dict-ca, aspell-dict-it): Use 'hash' and 'content-hash' for proper syntax matching. * gnu/packages/bash.scm (bash-patch): Rename 'sha256' to 'sha256-bv'. * gnu/packages/bootstrap.scm (bootstrap-executable): Rename 'sha256' to 'bv'. * gnu/packages/readline.scm (readline-patch): Likewise. * gnu/packages/virtualization.scm (qemu-patch): Rename 'sha256' to 'sha256-bv'. * guix/import/utils.scm: Hide (gcrypt hash) 'sha256'. 2020-03-14Merge branch 'master' into core-updatesMarius Bakke 2020-03-10gnu: bash-tap: Use HTTPS home page.Tobias Geerinckx-Rice * gnu/packages/bash.scm (bash-tap)[home-page]: Use HTTPS. 2020-02-15gnu: bash: Update to 5.0.16.Marius Bakke * gnu/packages/bash.scm (%patch-series-5.0): Add patches 12 through 16. 2019-12-31Merge remote-tracking branch 'master' into core-updates.Mathieu Othacehe 2019-12-20gnupg: 'gnupg-verify*' returns a status symbol.Ludovic Courtès This allows callers to distinguish between signature verification failure and missing key. * guix/gnupg.scm (gnupg-receive-keys): Return true on success. (gnupg-verify*): Check return value of 'gnupg-receive-keys'. Return two values, the first one being a symbol. * guix/upstream.scm (download-tarball): Get the two return values of 'gnupg-verify*', and match on the first one. * gnu/packages/bash.scm (download-patches): Check the first return value of 'gnupg-verify*'. 2019-11-27gnu: bash: Update to patch level 11.Efraim Flashner * gnu/packages/bash.scm (%patch-series-5.0): Add patches 8 through 11. 2019-11-16Merge remote-tracking branch master into core-updatesMathieu Othacehe 2019-11-03gnu: bash-tap: Don't use unstable tarball.Tobias Geerinckx-Rice * gnu/packages/bash.scm (bash-tap)[source]: Use GIT-FETCH and GIT-FILE-NAME. 2019-09-23gnu: bash: Unconditionally configure PGRP_PIPE for *-linux systems.Mark H Weaver * gnu/packages/patches/bash-linux-pgrp-pipe.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bash.scm (bash)[source]: Add the patch. 2019-06-27Merge branch 'master' into core-updatesLudovic Courtès 2019-06-25gnu: bash-completion: Fix cross-compilation.Mathieu Othacehe * gnu/packages/bash.scm (bash-completion)[arguments]: Search for util-linux in native-inputs and inputs during "remove-redundant-completions" phase. 2019-05-26gnu: bash: Update to patch level 7.Efraim Flashner * gnu/packages/bash.scm (%patch-series-5.0): Add patches 3 through 7. 2019-03-02gnu: bash: Update to patch level 2.Efraim Flashner * gnu/packages/bash.scm (%patch-series-5.0): Add patches 1 and 2. [source]: Apply patches. [version]: Update with patch numbers. 2019-01-08gnu: bash: Update to 5.0.Efraim Flashner * gnu/packages/bash.scm (bash): Update to 5.0. [source]: Remove patches. (patch-url seqno): Prepare for bash-5.0 patches. (%patch-series-4.4): Rename %patch-series-5.0, remove patches.