aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2024-06-17 11:00:11 -0400
committerEfraim Flashner <efraim@flashner.co.il>2024-07-09 17:09:46 +0300
commit7b0df27906d010aa7d0b695e35c0b40a911c58a8 (patch)
tree5645df562865561eba537089174e2d0f4085dd0e /gnu/packages/chez.scm
parent21402e6193799e132781bad4387ad410dbbfa93c (diff)
downloadguix-7b0df27906d010aa7d0b695e35c0b40a911c58a8.tar.gz
guix-7b0df27906d010aa7d0b695e35c0b40a911c58a8.zip
gnu: chez-scheme: Backport test fix.
The backported commit fixes crashes when signals are delivered to non-Scheme threads, including GC worker threads and threads created by foreign libraries. This appears to have been the cause of the intermittent test failures we have experienced. * gnu/packages/patches/chez-scheme-backport-signal.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/chez-scheme.scm (chez-scheme)[source]<patches>: Use it. (chez-scheme-for-racket, chez-scheme): Enable tests. Change-Id: Ifd87ca0d1707ef6ad067d883772a5b42803ead94 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index dd98966c78..8c52bbb188 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -329,8 +329,6 @@ will name the threaded machine type unless THREADS? is provided as #f."
(ice-9 match)
(srfi srfi-34))
#:out-of-source? #t
- ;; Intermittent failures: https://github.com/cisco/ChezScheme/issues/809
- #:tests? #f
#:test-target "test" ; test-one test-some-fast test-some test test-more
#:configure-flags
#~`(,@(let* ((chez+version (strip-store-file-name #$output))
@@ -509,6 +507,7 @@ version of Chez Scheme.")
"1q66vafhiwk617z51qkm1v64r3bxqhhf5lzrmsa4l9d5yhvlyk09"))
(file-name (git-file-name name version))
(patches (search-patches "chez-scheme-backport-configure.patch"
+ "chez-scheme-backport-signal.patch"
"chez-scheme-bin-sh.patch"))
(snippet #~(begin
(use-modules (guix build utils))