aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-12 08:06:10 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:10 +0000
commitaa31723ce0275a43a84f861e23d9a5cc50a82bf0 (patch)
treef84213065d34cfee64657b6651745d5bc9939e87 /gnu/packages/check.scm
parent5cdd45f0f155787b13eccc63c60f71ee123ff58b (diff)
downloadguix-aa31723ce0275a43a84f861e23d9a5cc50a82bf0.tar.gz
guix-aa31723ce0275a43a84f861e23d9a5cc50a82bf0.zip
gnu: python-pytest-mock: Update to 3.14.0.
* gnu/packages/check.scm (python-pytest-mock): Update to 3.14.0. Simplify package. [snippet]: Remove it. [build-system]: Swap to pyproject-build-system. [argument]<phases>: Use default 'check phase. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ia7eb5d6ee6a10de53a106909946e90b72b12fe99
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm35
1 files changed, 11 insertions, 24 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5fc9767df1..cb5a385515 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2008,37 +2008,24 @@ Python's @code{random.seed}.")
(define-public python-pytest-mock
(package
(name "python-pytest-mock")
- (version "3.10.0")
+ (version "3.14.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-mock" version))
(sha256
- (base32 "0kzdwwdjw001qzf1n4qzh7c364rvmb0cmkfqdwr2l9bwxy2v1ggv"))
- (modules '((guix build utils)))
- (snippet
- ;; Some tests do a string match on Pytest output, and fails when
- ;; warnings are present. Adjust to cope with warnings from
- ;; third-party libraries (looking at you, pytest-asyncio).
- '(substitute* "tests/test_pytest_mock.py"
- (("1 passed in \\*")
- "1 passed*")))))
- (build-system python-build-system)
+ (base32 "1l0b864arbzrq13z635l1x9ial0w7pgz6svd0nyavkpy3rd2a697"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Skip the assertion rewriting tests, which don't work in the
- ;; presence of read-only Python modules (a limitation of
- ;; Pytest). Also skip the "test_standalone_mock" test, which
- ;; can only work when 'python-mock' is not available
- ;; (currently propagated by Pytest 5).
- (invoke "pytest" "--assert=plain" "-vv"
- "-k" "not test_standalone_mock")))))))
+ (list
+ ;; Skip the assertion rewriting tests, which don't work in the presence
+ ;; of read-only Python modules (a limitation of Pytest).
+ #:test-flags #~(list "--assert=plain")))
(native-inputs
- (list python-pytest-asyncio python-setuptools-scm))
+ (list python-pytest-asyncio
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-pytest))
(home-page "https://github.com/pytest-dev/pytest-mock/")