aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-09-20 12:00:51 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-09-29 11:10:30 +0200
commit93ceb2d90165fa5e76f983f252f09bf97f3b17d8 (patch)
tree47c209972ec5d198a54d04e18e9e0e6a4cbd6f25 /gnu/packages/check.scm
parent786eb92c0f1ea8a22c9cf160440cd0722052e6f8 (diff)
downloadguix-93ceb2d90165fa5e76f983f252f09bf97f3b17d8.tar.gz
guix-93ceb2d90165fa5e76f983f252f09bf97f3b17d8.zip
gnu: rapidcheck: Fix pkg-config libs.
Using rapidcheck as a dependency in a project currently results in a linker error, because the pkg-config file is missing relevant linker flags. * gnu/packages/patches/rapidcheck-fix-libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/check.scm (rapidcheck)[patches]: Use it here.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index f56f7e5a83..8d41996c71 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3798,6 +3798,7 @@ provides a simple way to achieve this.")
(sha256
(base32 "1s2qva1amhs887jcdj12ppxk9kkfvy25xy7vzhkwb7rljr3gj713"))
(modules '((guix build utils)))
+ (patches (search-patches "rapidcheck-fix-libs.patch"))
(snippet
#~(begin
(make-file-writable "ext/CMakeLists.txt")