aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-24 13:27:08 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:56 +0200
commit86d5774605654ece8c6d1e22cdcd7ad88d5320d9 (patch)
treef86ce956a725d4fda7afe4fde1ada9fc7e135a69 /gnu/packages/check.scm
parentd1b8834927d50d736d1a08a2f26b9f8d2dca6fed (diff)
downloadguix-86d5774605654ece8c6d1e22cdcd7ad88d5320d9.tar.gz
guix-86d5774605654ece8c6d1e22cdcd7ad88d5320d9.zip
gnu: Add atf.
* gnu/packages/check.scm (atf): New variable. * gnu/packages/patches/atf-execute-with-shell.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I37a57069380309382bc0ff24977a1fd165985f5e
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm40
1 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a2256fdcf8..ac3a2d9a20 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -35,7 +35,7 @@
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022, 2023 David Elsing <david.elsing@posteo.net>
@@ -123,6 +123,44 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public atf
+ (package
+ (name "atf")
+ (version "0.21")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/freebsd/atf")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jwzz6g9jdi5f8v10y0wf3hq73vxyv5qqhkh832ddsj36gn8rlcz"))
+ (patches (search-patches "atf-execute-with-shell.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "ATF_SHELL="
+ #$(this-package-input "bash-minimal")
+ "/bin/sh"))))
+ (native-inputs (list autoconf automake libtool))
+ (inputs (list bash-minimal))
+ (home-page "https://github.com/freebsd/atf")
+ (synopsis "C/C++ Automated Testing Framework libraries")
+ (description "ATF, or Automated Testing Framework, is a collection of
+libraries to write test programs in C, C++ and POSIX shell.
+
+The ATF libraries offer a simple API. The API is orthogonal through the
+various bindings, allowing developers to quickly learn how to write test
+programs in different languages.
+
+ATF-based test programs offer a consistent end-user command-line interface to
+allow both humans and automation to run the tests.
+
+ATF-based test programs rely on an execution engine to be run and this
+execution engine is not shipped with ATF. Kyua is the engine of choice.")
+ (license (list license:bsd-2 license:bsd-3))))
+
(define-public pict
(package
(name "pict")