aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-06 12:26:47 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:33:12 +0100
commitb8c5057e50370d9f65ef7565afe11666528b341a (patch)
tree7b775da689b2f3e24b52d73aebb65938b2295926 /gnu/packages/bootstrap.scm
parent94dfb68d4378377dfe49d6653e4ed668cecd2783 (diff)
downloadguix-b8c5057e50370d9f65ef7565afe11666528b341a.tar.gz
guix-b8c5057e50370d9f65ef7565afe11666528b341a.zip
gnu: cross-libc: Support cross-building for the 64bit Hurd.
* gnu/packages/base.scm (glibc)[arguments]: When building for the Hurd, in phase "create-machine-symlink", do not assume CPU is i386, also cater for x86_64. * gnu/packages/cross-base.scm (cross-libc*)[arguments]: Likewise. Change-Id: Ib009b7bd301b543b8629382330cca9d963b7a812
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 33cbaa30ae..27798fe278 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -311,7 +311,7 @@ or false to signal an error."
gnu-triplet->nix-system)
(%current-system))))
"Return the name of Glibc's dynamic linker for SYSTEM."
- ;; See the 'SYSDEP_KNOWN_INTERPRETER_NAMES' cpp macro in libc.
+ ;; See the appropriate 'shlib-versions' file in libc.
(let ((platform (false-if-platform-not-found
(lookup-platform-by-system system))))
(cond