aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-05 13:01:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-12-05 13:01:18 +0200
commit76bc375080486254456cec6d4b4baab01aa67ca1 (patch)
tree9209d883150e5cd0494d57c599f04239831f29a5 /gnu/packages/bootstrap.scm
parent006679d1e6ca7acea0629b4f019c8cf89cde08be (diff)
downloadguix-76bc375080486254456cec6d4b4baab01aa67ca1.tar.gz
guix-76bc375080486254456cec6d4b4baab01aa67ca1.zip
gnu: glibc-dynamic-linker: Match all mingw systems.
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Match any system which ends in '-mingw'. Change-Id: I057e3d0abfc37f4b2b8784f444bbaf865c67ce3e
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index f2620f844c..db20e71fe0 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -340,10 +340,9 @@ or false to signal an error."
;; here just so we can keep going.
((string=? system "arm-eabi") "no-ld.so")
((string=? system "avr") "no-ld.so")
- ((string=? system "i686-mingw") "no-ld.so")
((string=? system "or1k-elf") "no-ld.so")
- ((string=? system "x86_64-mingw") "no-ld.so")
((string-suffix? "-elf" system) "no-ld.so")
+ ((string-suffix? "-mingw" system) "no-ld.so")
(else (error "dynamic linker name not known for this system"
system)))))