aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-17 12:27:48 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:39:01 +0100
commit204fe1b1f05f4438d1cf72c568b45696e55e54c9 (patch)
treec6e1171f5015e81a3e475230061aece020db5035 /gnu/packages/bootstrap.scm
parentbaf4a3330762d184f5b10846151a9e3afd7c3dbe (diff)
downloadguix-204fe1b1f05f4438d1cf72c568b45696e55e54c9.tar.gz
guix-204fe1b1f05f4438d1cf72c568b45696e55e54c9.zip
gnu: bootstrap: %bootstrap-glibc: Also fix libm.so.
On the 64bit Hurd, glibc-2.39's libm.so is also a linker script. This fixes having it refer to /gnu/store/eee...-glibc-cross-x86_64-pc-gnu-2.39/lib/libm.so.6 /gnu/store/eee...-glibc-cross-x86_64-pc-gnu-2.39/lib/libmvec.so.1 * gnu/packages/bootstrap.scm (%bootstrap-glibc)[arguments]: When building for the 64bit Hurd, also substitute libm.so linker script. Update the regexp to also cater for libh[urduser] and libm[achuser]. Change-Id: I878e63d18f1012b6e186e90eb68cb97bec5ae94c
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 8027918323..a6cdda2122 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -774,12 +774,12 @@ $out/bin/guile --version~%"
"/binaries.tar"))
(chmod "lib" #o755)
- ;; Patch libc.so so it refers to the right path.
- (substitute* "lib/libc.so"
- (("/[^ ]+/lib/(libc|ld)" _ prefix)
- (string-append out "/lib/" prefix)))
-
- #t))))))
+ ;; Patch linker scripts so they refer to the right file-names.
+ (substitute* ,(if (target-hurd64?)
+ ''("lib/libc.so" "lib/libm.so")
+ "lib/libc.so")
+ (("/[^ ]+/lib/(libc|libm|libh|ld)" _ prefix)
+ (string-append out "/lib/" prefix)))))))))
(inputs
`(("tar" ,(bootstrap-executable "tar" (%current-system)))
("xz" ,(bootstrap-executable "xz" (%current-system)))