aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-08 23:07:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 14:37:03 +0100
commit5b0e656e5786a3503be6e35e70160bcfa10d8dea (patch)
tree2a28d28f99db53b82e3577b63914fc1b72508e8b /gnu/packages/bootloaders.scm
parentad4bb682d35e2d6246c4b8cd0b2e5396d05bd242 (diff)
downloadguix-5b0e656e5786a3503be6e35e70160bcfa10d8dea.tar.gz
guix-5b0e656e5786a3503be6e35e70160bcfa10d8dea.zip
gnu: u-boot: Update to 2022.10.
* gnu/packages/bootloaders.scm (u-boot): Update to 2022.10. * gnu/packages/patches/u-boot-allow-disabling-openssl.patch: Disable fit_pre_load_data, which depends on openssl.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 8888c51736..9fdcee01bb 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -631,7 +631,7 @@ tree binary files. These are board description files used by Linux and BSD.")
(define u-boot
(package
(name "u-boot")
- (version "2022.04")
+ (version "2022.10")
(source (origin
(patches
(list %u-boot-rockchip-inno-usb-patch
@@ -644,7 +644,8 @@ tree binary files. These are board description files used by Linux and BSD.")
"u-boot-" version ".tar.bz2"))
(sha256
(base32
- "1l5w13dznj0z1ibqv2d6ljx2ma1gnf5x5ay3dqkqwxr6750nbq38"))))
+ "1y5x8vxdgsqdqlsvq01mn8lmw53fqairkhvhhjx83hjva0m4id2h"))))
+ (build-system gnu-build-system)
(native-inputs
`(("bc" ,bc)
("bison" ,bison)
@@ -660,7 +661,6 @@ tree binary files. These are board description files used by Linux and BSD.")
("python-pytest" ,python-pytest)
("swig" ,swig)
("libuuid" ,util-linux "lib")))
- (build-system gnu-build-system)
(home-page "https://www.denx.de/wiki/U-Boot/")
(synopsis "ARM bootloader")
(description "U-Boot is a bootloader used mostly for ARM boards. It