aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-27 11:40:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-27 11:40:09 +0200
commitfa685c87eaa9888a4278f39bb2b815673589dced (patch)
tree05d74cb4a09a889b0bc8a936a1fbc2472c50efbe /gnu/packages/bioinformatics.scm
parent133957f7bb81d9c9f33216ea8afe649866267b5e (diff)
downloadguix-fa685c87eaa9888a4278f39bb2b815673589dced.tar.gz
guix-fa685c87eaa9888a4278f39bb2b815673589dced.zip
gnu: freebayes: Update to 1.3.7.
* gnu/packages/bioinformatics.scm (freebayes): Update to 1.3.7. [arguments]: Do not use "grep -P" in tests; drop trailing #T.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 113bdc5675..181e68b44b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17339,7 +17339,7 @@ manipulations on VCF files.")
(define-public freebayes
(package
(name "freebayes")
- (version "1.3.5")
+ (version "1.3.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -17347,12 +17347,7 @@ manipulations on VCF files.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1l0z88gq57kva677a6xri5g9k2d9h9lk5yk1q2xmq64wqhv7dvc3"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "contrib/htslib")
- #t))))
+ (base32 "163nd1xkq547za80khlys4qkgal64f3sgl6ap3yvik68r0rgyisv"))))
(build-system meson-build-system)
(inputs
(list fastahack htslib smithwaterman tabixpp vcflib))
@@ -17392,25 +17387,27 @@ manipulations on VCF files.")
(substitute* '("src/BedReader.cpp"
"src/BedReader.h")
(("../intervaltree/IntervalTree.h") "IntervalTree.h"))
+ ;; We don't have Perl support in grep -E.
+ (substitute* '("test/t/01_call_variants.t"
+ "test/t/01b_call_variants.t")
+ (("grep -P") "grep -E")
+ (("\\\\t") " "))
(substitute* "meson.build"
;; Our pkg-config file is vcflib.pc
(("libvcflib") "vcflib")
- (("vcflib_inc,") ""))
- #t)))
+ (("vcflib_inc,") "")))))
(add-after 'unpack 'unpack-submodule-sources
(lambda* (#:key inputs #:allow-other-keys)
(mkdir-p "test/test-simple-bash")
(copy-recursively (assoc-ref inputs "test-simple-bash-src")
- "test/test-simple-bash")
- #t))
+ "test/test-simple-bash")))
;; The slow tests take longer than the specified timeout.
,@(if (any (cute string=? <> (%current-system))
'("armhf-linux" "aarch64-linux"))
'((replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "meson" "test" "--timeout-multiplier" "5"))
- #t)))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "meson" "test" "--timeout-multiplier" "5")))))
'()))))
(home-page "https://github.com/freebayes/freebayes")
(synopsis "Haplotype-based variant detector")