aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-26 17:10:39 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-02 11:33:13 +0100
commitd57e6d0f8ef6014528b0fcfd3f900c16065d1960 (patch)
treedcb88c203c3722ce4603abb6b10b48452935f2b2 /gnu/packages/bioinformatics.scm
parenta2fb1492afe9e22102ee2404f1b546ee655ec7ac (diff)
downloadguix-d57e6d0f8ef6014528b0fcfd3f900c16065d1960.tar.gz
guix-d57e6d0f8ef6014528b0fcfd3f900c16065d1960.zip
gnu: Add MACS.
* gnu/packages/bioinformatics.scm (macs): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a919da8b51..2d6251ac92 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -368,6 +368,37 @@ particular, reads spanning multiple exons.")
from high-throughput sequencing assays.")
(license license:gpl3+)))
+(define-public macs
+ (package
+ (name "macs")
+ (version "2.1.0.20140616")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/M/MACS2/MACS2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "11lmiw6avqhwn75sn59g4lfkrr2kk20r3rgfbx9xfqb8rg9mi2n6"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2 ; only compatible with Python 2.7
+ #:tests? #f)) ; no test target
+ (inputs
+ `(("python-numpy" ,python2-numpy)))
+ (native-inputs
+ `(("python-setuptools" ,python2-setuptools)))
+ (home-page "http://github.com/taoliu/MACS/")
+ (synopsis "Model based analysis for ChIP-Seq data")
+ (description
+ "MACS is an implementation of a ChIP-Seq analysis algorithm for
+identifying transcript factor binding sites named Model-based Analysis of
+ChIP-Seq (MACS). MACS captures the influence of genome complexity to evaluate
+the significance of enriched ChIP regions and it improves the spatial
+resolution of binding sites through combining the information of both
+sequencing tag position and orientation.")
+ (license license:bsd-3)))
+
(define-public rseqc
(package
(name "rseqc")