aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-13 14:53:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 16:31:54 +0100
commit8cc22866c283f49c14f7b7419f57c40c8eee1f56 (patch)
tree3cbecba416ddb2e72947c8f93fe4414a958cd45a /gnu/packages/bioinformatics.scm
parent6d2afaf25b40bc055374cc1a1bf85efa1fb2e6fb (diff)
downloadguix-8cc22866c283f49c14f7b7419f57c40c8eee1f56.tar.gz
guix-8cc22866c283f49c14f7b7419f57c40c8eee1f56.zip
gnu: bamtools: Update to 2.5.2.
* gnu/packages/bioinformatics.scm (bamtools): Update to 2.5.2. [arguments]: Enable tests; remove extra phases. [inputs]: Add jsoncpp. [native-inputs]: Add pkg-config.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9dcc5bc92c..0f3d8010af 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -219,7 +219,7 @@ structure of the predicted RNA.")
(define-public bamtools
(package
(name "bamtools")
- (version "2.5.1")
+ (version "2.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -228,21 +228,10 @@ structure of the predicted RNA.")
(file-name (git-file-name name version))
(sha256
(base32
- "0nfb2ypcx9959xnbz6wxh6py3xfizgmg8nrknxl95c507m9hmq8b"))))
+ "14lw571vbks138i0lj66qjdbk8iwa817x2zbpzij61vv1gdgfbn5"))))
(build-system cmake-build-system)
- (arguments
- `(#:tests? #f ;no "check" target
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'configure 'set-ldflags
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "LDFLAGS"
- (string-append
- "-Wl,-rpath="
- (assoc-ref outputs "out") "/lib/bamtools"))
- #t)))))
- (inputs (list zlib))
+ (inputs (list jsoncpp zlib))
+ (native-inputs (list pkg-config))
(home-page "https://github.com/pezmaster31/bamtools")
(synopsis "C++ API and command-line toolkit for working with BAM data")
(description