aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-07-01 14:53:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-01 14:54:26 +0200
commit81cf674a5d5e3dc020df5d43ce62e1c98f2c9711 (patch)
tree02745fc23ee47c8242c0a933bbd084cb9c4e4a7d /gnu/packages/bioinformatics.scm
parent741895676b124a8a9a6656a54b5b58fd35d8e0f9 (diff)
downloadguix-81cf674a5d5e3dc020df5d43ce62e1c98f2c9711.tar.gz
guix-81cf674a5d5e3dc020df5d43ce62e1c98f2c9711.zip
gnu: Add python-ikarus.
* gnu/packages/bioinformatics.scm (python-ikarus): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 75973b0dd8..be19658417 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13520,6 +13520,53 @@ transcription factors, gene regulatory networks and cell types from
single-cell RNA-seq data.")
(license license:gpl3+)))
+(define-public python-ikarus
+ (package
+ (name "python-ikarus")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ikarus" version))
+ (sha256
+ (base32
+ "086czpvj4yafz4vrq5rx2gy0bj2l8nzwnkk0gw8qvy4w133xjysy"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #false
+ #:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/BIMSBbioinfo/ikarus/issues/12
+ (add-after 'unpack 'fix-issue-12
+ (lambda _
+ (substitute* "ikarus/classifier.py"
+ (("pyscenic.genesig") "ctxcore.genesig"))))
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'check 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs
+ (list python-numpy
+ python-pandas
+ python-scipy
+ python-scanpy
+ python-anndata
+ python-ctxcore ;because of issue 12
+ pyscenic))
+ (home-page "https://github.com/BIMSBbioinfo/ikarus")
+ (synopsis "Machine learning classifier of tumor cells")
+ (description
+ "ikarus is a stepwise machine learning pipeline that tries to cope with a task
+of distinguishing tumor cells from normal cells. Leveraging multiple
+annotated single cell datasets it can be used to define a gene set specific to
+tumor cells. First, the latter gene set is used to rank cells and then to
+train a logistic classifier for the robust classification of tumor and normal
+cells. Finally, sensitivity is increased by propagating the cell labels based
+on a custom cell-cell network. ikarus is tested on multiple single cell
+datasets to ascertain that it achieves high sensitivity and specificity in
+multiple experimental contexts.")
+ (license license:expat)))
+
(define-public vbz-compression
(package
(name "vbz-compression")