aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-14 13:29:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-14 13:29:34 +0200
commit6754eb339c559d27beed718e16ec001ef38483fa (patch)
tree8be3ace187d771afd3405a5f2a698f34755c5da9 /gnu/packages/bioinformatics.scm
parent302e7b7820606de4cd7034ea367c2028a8fca4e2 (diff)
downloadguix-6754eb339c559d27beed718e16ec001ef38483fa.tar.gz
guix-6754eb339c559d27beed718e16ec001ef38483fa.zip
gnu: delly: Simplify.
* gnu/packages/bioinformatics.scm (delly)[source]: Simplify snippet. [arguments]: Do not use quasiquote; simplify 'install-templates phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1e9abd3c63..13f16ce026 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4027,25 +4027,23 @@ with Python.")
(base32 "1ibnplgfzj96w8glkx17v7sld3pm402fr5ybmf3h0rlcryabxrqy"))
(modules '((guix build utils)))
(snippet
- '(begin
- (delete-file-recursively "src/htslib")
- #t))))
+ '(delete-file-recursively "src/htslib"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; There are no tests to run.
- #:make-flags
- ,#~(list "PARALLEL=1" ; Allow parallel execution at run-time.
- (string-append "prefix=" #$output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; There is no configure phase.
- (add-after 'install 'install-templates
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((templates (string-append (assoc-ref outputs "out")
- "/share/delly/templates")))
- (mkdir-p templates)
- (copy-recursively "excludeTemplates" templates)
- #t))))))
+ (list
+ #:tests? #f ;There are no tests to run.
+ #:make-flags
+ #~(list "PARALLEL=1" ; Allow parallel execution at run-time.
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (add-after 'install 'install-templates
+ (lambda _
+ (let ((templates (string-append #$output
+ "/share/delly/templates")))
+ (mkdir-p templates)
+ (copy-recursively "excludeTemplates" templates)))))))
(inputs
(list boost bzip2 htslib zlib))
(home-page "https://github.com/dellytools/delly")