aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-04-21 02:03:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-21 14:01:22 +0200
commit2a20acf24b964e527b69f8b1111a3fdee1a56f68 (patch)
treedf1a8bc0673530f71b8c7d8892453d88bca8ef45 /gnu/packages/bioinformatics.scm
parent2babf3d7d70a52c3543500f09f31c4eaf7a5184e (diff)
downloadguix-2a20acf24b964e527b69f8b1111a3fdee1a56f68.tar.gz
guix-2a20acf24b964e527b69f8b1111a3fdee1a56f68.zip
gnu: bpp-popgen: Update to 2.4.1.
* gnu/packages/bioinformatics.scm (bpp-popgen): Update to 2.4.1. [source]: Remove the commit and use the release version. Changed to the github repo. [arguments]: Remove the disabled parallel-build. [home-page]: Changed to new host Université Claude-Bernard Lyon 1.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm49
1 files changed, 22 insertions, 27 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c032d107cd..152cef2e01 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2296,35 +2296,30 @@ library. It is part of the Bio++ project.")
(license license:cecill)))
(define-public bpp-popgen
- ;; The last release was in 2014 and the recommended way to install from source
- ;; is to clone the git repository, so we do this.
- ;; http://biopp.univ-montp2.fr/wiki/index.php/Main_Page
- (let ((commit "e472bac9b1a148803895d747cd6d0c5904f85d9f"))
- (package
- (name "bpp-popgen")
- (version (string-append "2.2.0-1." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://biopp.univ-montp2.fr/git/bpp-popgen")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0yn82dzn1n5629nzja68xfrhi655709rjanyryb36vzkmymy6dw5"))))
- (build-system cmake-build-system)
- (arguments
- `(#:parallel-build? #f
- #:tests? #f)) ; There are no tests.
- (inputs
- (list bpp-core bpp-seq))
- (home-page "http://biopp.univ-montp2.fr")
- (synopsis "Bio++ population genetics library")
- (description
- "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
+ (package
+ (name "bpp-popgen")
+ (version "2.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BioPP/bpp-popgen")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bz0fhrq3dri6a0hvfc3zlvrns8mrzzlnicw5pyfa812gc1qwfvh"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ; There are no tests.
+ (inputs
+ (list bpp-core bpp-seq))
+ (home-page "https://pbil.univ-lyon1.fr/bpp-doc/bpp-popgen/html/")
+ (synopsis "Bio++ population genetics library")
+ (description
+ "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
analysis, phylogenetics, molecular evolution and population genetics. This
library provides population genetics-related modules.")
- (license license:cecill-c))))
+ (license license:cecill-c)))
(define-public bpp-seq
(package