aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-12 21:34:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-12 21:34:07 +0200
commit2794caed7c813f2ec4249236de36eaccafee8361 (patch)
tree8c073428e5d7f6b9f808b122893cb561e934aa78 /gnu/packages/bioinformatics.scm
parent3b524cde7115a6e89a438c1fd230093e6f30442f (diff)
downloadguix-2794caed7c813f2ec4249236de36eaccafee8361.tar.gz
guix-2794caed7c813f2ec4249236de36eaccafee8361.zip
gnu: Add r-numbat.
* gnu/packages/bioinformatics.scm (r-numbat): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9342c44474..341731d066 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -875,6 +875,78 @@ attributes of microbiome data - zero-inflation and over-dispersion, are
simultaneously considered.")
(license license:gpl3))))
+(define-public r-numbat
+ (let ((commit "4ab7752e7d267a3f443756675728521a9b0a7295")
+ (revision "1"))
+ (package
+ (name "r-numbat")
+ (version (git-version "1.3.2-1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kharchenkolab/numbat")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wa2cz5iy570r2a57bd74jramxayvfhmxznb0vq4vyk1ia8l5jd1"))))
+ (properties `((upstream-name . "numbat")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ape
+ r-catools
+ r-data-table
+ r-dendextend
+ r-dplyr
+ r-genomicranges
+ r-ggplot2
+ r-ggraph
+ r-ggtree
+ r-glue
+ r-igraph
+ r-iranges
+ r-logger
+ r-magrittr
+ r-matrix
+ r-optparse
+ r-paralleldist
+ r-patchwork
+ r-pryr
+ r-purrr
+ r-r-utils
+ r-rcpp
+ r-rcpparmadillo
+ r-rhpcblasctl
+ r-roptim
+ r-scales
+ r-scistreer
+ r-stringr
+ r-tibble
+ r-tidygraph
+ r-tidyr
+ r-vcfr
+ r-zoo))
+ (home-page "https://github.com/kharchenkolab/numbat")
+ (synopsis "Haplotype-Aware CNV Analysis from scRNA-Seq")
+ (description
+ "This package provides a computational method that infers copy number
+variations (CNVs) in cancer scRNA-seq data and reconstructs the tumor
+phylogeny. numbat integrates signals from gene expression, allelic ratio, and
+population haplotype structures to accurately infer allele-specific CNVs in
+single cells and reconstruct their lineage relationship. numbat can be used
+to:
+
+@enumerate
+@item detect allele-specific copy number variations from single-cells;
+@item differentiate tumor versus normal cells in the tumor microenvironment;
+@item infer the clonal architecture and evolutionary history of profiled
+tumors.
+@end enumerate
+
+numbat does not require tumor/normal-paired DNA or genotype data, but operates
+solely on the donor scRNA-data data (for example, 10x Cell Ranger output).")
+ (license license:expat))))
+
(define-public r-p2data
(let ((commit "7d4c0e17d7899f9d9b08ab2bf455abe150912f4c")
(revision "1"))