aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-06 14:05:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-06 14:05:58 +0100
commit067c8a7445fbe030d0f4480282e6a6beb2c1997f (patch)
tree588d1c807fc51a921d0bc250e70ec2e7d9da3336 /gnu/packages/bioinformatics.scm
parent0070e52ade4d521e21ecf8da10a3485aa2615dc3 (diff)
downloadguix-067c8a7445fbe030d0f4480282e6a6beb2c1997f.tar.gz
guix-067c8a7445fbe030d0f4480282e6a6beb2c1997f.zip
gnu: filtlong: Use gexp.
* gnu/packages/bioinformatics.scm (filtlong)[arguments]: Use gexp.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4bc4dde36c..1dd847f369 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14321,29 +14321,28 @@ phase + query phase).")
(base32 "1xr92r820x8qlkcr3b57iw223yq8vjgyi42jr79w2xgw47qzr575"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (scripts (string-append out "/share/filtlong/scripts")))
- (install-file "bin/filtlong" bin)
- (install-file "scripts/histogram.py" scripts)
- (install-file "scripts/read_info_histograms.sh" scripts))))
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (path (getenv "GUIX_PYTHONPATH")))
- (wrap-program (string-append out
- "/share/filtlong/scripts/histogram.py")
- `("GUIX_PYTHONPATH" ":" prefix (,path))))))
- (add-before 'check 'patch-tests
- (lambda _
- (substitute* "scripts/read_info_histograms.sh"
- (("awk") (which "gawk"))))))))
+ (list
+ #:tests? #f ; no check target
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (let ((bin (string-append #$output "/bin"))
+ (scripts (string-append #$output "/share/filtlong/scripts")))
+ (install-file "bin/filtlong" bin)
+ (install-file "scripts/histogram.py" scripts)
+ (install-file "scripts/read_info_histograms.sh" scripts))))
+ (add-after 'install 'wrap-program
+ (lambda _
+ (let ((path (getenv "GUIX_PYTHONPATH")))
+ (wrap-program (string-append #$output
+ "/share/filtlong/scripts/histogram.py")
+ `("GUIX_PYTHONPATH" ":" prefix (,path))))))
+ (add-before 'check 'patch-tests
+ (lambda _
+ (substitute* "scripts/read_info_histograms.sh"
+ (("awk") (which "gawk"))))))))
(inputs
(list gawk ;for read_info_histograms.sh
python-2 ;required for histogram.py