aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-01-30 22:44:57 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-08-26 14:13:56 +0200
commit257375d36bdf8cf150e984218f837a8054ce6fa1 (patch)
tree79ce110f422cb63cb08303d0d3d6fbc7b06cde1a /gnu/packages/bioconductor.scm
parent7578bf8457c49f1e74585be84d0a6b91078461bd (diff)
downloadguix-257375d36bdf8cf150e984218f837a8054ce6fa1.tar.gz
guix-257375d36bdf8cf150e984218f837a8054ce6fa1.zip
gnu: Add r-hmmcopy.
* gnu/packages/bioconductor.scm (r-hmmcopy): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Change-Id: Iface547e865609427c356277edc904f3aec386d8
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 75b5566586..c062c9e803 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2021 Nicolas Vallet <nls.vallet@gmail.com>
;;; Copyright © 2023 Navid Afkhami <Navid.Afkhami@mdc-berlin.de>
+;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -14505,6 +14506,30 @@ algorithm to segment DNA copy number data and identify genomic regions with
abnormal copy number.")
(license license:gpl2+)))
+(define-public r-hmmcopy
+ (package
+ (name "r-hmmcopy")
+ (version "1.44.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "HMMcopy" version))
+ (sha256
+ (base32 "1nhm8bv6p5zcs7f9p1hqzyjgya6v3q8rl13blh135pk9gxjiad2c"))))
+ (properties `((upstream-name . "HMMcopy")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-data-table))
+ (home-page "https://bioconductor.org/packages/HMMcopy")
+ (synopsis
+ "Copy number prediction with correction for GC and mappability bias for HTS data")
+ (description
+ "This package corrects GC and mappability biases for
+readcounts (i.e. coverage) in non-overlapping windows of fixed length for
+single whole genome samples, yielding a rough estimate of copy number for
+further analysis. It was designed for rapid correction of high coverage whole
+genome tumor and normal samples.")
+ (license license:gpl3)))
+
;; This is a CRAN package, but it uncharacteristically depends on a
;; Bioconductor package.
(define-public r-htscluster