aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-25 23:36:11 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-25 23:48:37 -0500
commit0d41fe4855588fb659b8adafe215d5573517a79b (patch)
tree38b274bd03375f4fa5b7d3a9fb3f64a19786bef2 /gnu/packages/bash.scm
parent7c57821c68d199ad56a8ed750b36eccc7ef238dd (diff)
parent1a5302435ff0d2822b823f5a6fe01faa7a85c629 (diff)
downloadguix-0d41fe4855588fb659b8adafe215d5573517a79b.tar.gz
guix-0d41fe4855588fb659b8adafe215d5573517a79b.zip
Merge branch 'staging' into core-updates.
With "conflicts" resolved in (mostly in favor of master/staging): gnu/packages/admin.scm gnu/packages/gnuzilla.scm gnu/packages/gtk.scm gnu/packages/kerberos.scm gnu/packages/linux.scm guix/lint.scm
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index cf40ee94f6..72758560cd 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -269,6 +269,23 @@ without modification.")
(delete-file-recursively (string-append out "/share"))
#t))))))))))
+(define-public bash-with-syslog
+ (package
+ (inherit bash)
+ (name "bash-with-syslog")
+ (arguments
+ (substitute-keyword-arguments (package-arguments bash)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'enable-syslogging
+ (lambda _
+ (substitute* "config-top.h"
+ (("/\\* #define SYSLOG_HISTORY \\*/")
+ "#define SYSLOG_HISTORY"))))))))
+ (description
+ "Bash is the shell, or command-line interpreter, of the GNU system. This
+variant logs the history to syslog.")))
+
(define-public bash-completion
(package
(name "bash-completion")