aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-22 22:02:42 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 08:29:02 +0100
commitf5f345153ce02f3c1e5db9d77d8337de648d2540 (patch)
treeff75f40aa02216891448502877d3714154ff1e9f /gnu/packages/backup.scm
parent2e7d78b1f02a8eae82c34e5183134c9d1a0d02b3 (diff)
downloadguix-f5f345153ce02f3c1e5db9d77d8337de648d2540.tar.gz
guix-f5f345153ce02f3c1e5db9d77d8337de648d2540.zip
gnu: duplicity: Wrap for GI_TYPELIB_PATH.
* gnu/packages/backup.scm (duplicity) [native-inputs]: Add gobject-introspection. [inputs]: Add bash-minimal. [#:phases]: Add 'gi-wrap. Change-Id: If9d6a6bb0e855a4d775c1e4adb3b07f71be43090 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 3126464347..e627531102 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -118,6 +118,7 @@
(build-system python-build-system)
(native-inputs
(list gettext-minimal ; for msgfmt
+ gobject-introspection
util-linux ; setsid command, for the tests
par2cmdline
python-fasteners
@@ -132,7 +133,8 @@
(propagated-inputs
(list python-lockfile python-pygobject python-urllib3))
(inputs
- (list dbus ; dbus-launch (Gio backend)
+ (list bash-minimal ; to run the wrapped program
+ dbus ; dbus-launch (Gio backend)
librsync
lftp
gnupg ; gpg executable needed
@@ -172,7 +174,12 @@
"share/zoneinfo"))
;; Some things respect TMPDIR, others hard-code /tmp, and the
;; defaults don't match up, breaking test_restart. Fix it.
- (setenv "TMPDIR" "/tmp"))))))
+ (setenv "TMPDIR" "/tmp")))
+ (add-after 'wrap 'gi-wrap
+ (lambda _
+ (let ((prog (string-append #$output "/bin/duplicity")))
+ (wrap-program prog
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
(home-page "https://duplicity.gitlab.io/duplicity-web/")
(synopsis "Encrypted backup using rsync algorithm")
(description