aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-04-25 21:35:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-04-26 15:59:01 +0200
commite4f43b56c387d682913e2324f7965d18e486b5b7 (patch)
treeecc000002ad48be9570502601097468e1688e334 /gnu/packages/audio.scm
parentf763eaaaf94e048941885c8aa5aaf8d386d542a6 (diff)
downloadguix-e4f43b56c387d682913e2324f7965d18e486b5b7.tar.gz
guix-e4f43b56c387d682913e2324f7965d18e486b5b7.zip
gnu: Add fluidsynth.
* gnu/packages/audio.scm (fluidsynth): New variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8fb3da7fa1..96102db316 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -314,6 +314,45 @@ language and software synthesizer.")
ALSA PCM devices.")
(license license:gpl2+)))
+(define-public fluidsynth
+ (package
+ (name "fluidsynth")
+ (version "1.1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/fluidsynth/fluidsynth-"
+ version "/fluidsynth-" version ".tar.gz"))
+ (sha256
+ (base32
+ "070pwb7brdcn1mfvplkd56vjc7lbz4iznzkqvfsakvgbv68k71ah"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-cons-after
+ 'unpack
+ 'remove-broken-symlinks
+ (lambda _ (delete-file-recursively "m4") #t)
+ %standard-phases)))
+ (inputs
+ `(("libsndfile" ,libsndfile)
+ ("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("ladspa" ,ladspa)
+ ("lash" ,lash)
+ ("readline" ,readline)
+ ("glib" ,glib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.fluidsynth.org/")
+ (synopsis "SoundFont synthesizer")
+ (description
+ "FluidSynth is a real-time software synthesizer based on the SoundFont 2
+specifications. FluidSynth reads and handles MIDI events from the MIDI input
+device. It is the software analogue of a MIDI synthesizer. FluidSynth can
+also play midifiles using a Soundfont.")
+ (license license:gpl2+)))
+
(define-public faad2
(package
(name "faad2")