aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-21 19:38:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:46 +0000
commitf3431988d65317e0a59481ef416dc01cbcd41dc6 (patch)
tree1a5e21740e9469bd8be6a2dc4edb01ecae92aa6e /gnu/packages/astronomy.scm
parent201a8cd67599ff06f1c7b3dbd0a0cdfddd2bf46c (diff)
downloadguix-f3431988d65317e0a59481ef416dc01cbcd41dc6.tar.gz
guix-f3431988d65317e0a59481ef416dc01cbcd41dc6.zip
gnu: python-synphot: Update to 1.5.0.
* gnu/packages/astronomy.scm (python-synphot): Update to 1.5.0. Simplify package. [arguments]<phases>: Use default 'check phase. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Iccc0c2bedc7075af3da2bc0ffb822787d40d6f41
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm25
1 files changed, 9 insertions, 16 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 7d2b176002..2725a65061 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5829,36 +5829,29 @@ object.")
(define-public python-synphot
(package
(name "python-synphot")
- (version "1.4.0")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "synphot" version))
(sha256
- (base32 "0fk860bxaqbamrq15pkqlbvhbf70y50cra2mgvv9r0cxq37isbi6"))))
+ (base32 "0xifg0fbh2rj3jn5i504c0qh51dlzgr1l2k962nh38synjhq9csc"))))
(build-system pyproject-build-system)
(arguments
(list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? test-flags #:allow-other-keys)
- (when tests?
- (invoke "python" "setup.py" "build_ext" "--inplace")
- ;; Step out of the source directory to avoid interference; we
- ;; want to run the installed code with extensions etc.
- (with-directory-excursion "/tmp"
- (apply invoke "pytest" "-v" test-flags))))))))
+ #:test-flags #~(list "--pyargs" "synphot")))
+ (native-inputs
+ (list python-pytest
+ python-pytest-astropy
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-astropy
python-dust-extinction
python-numpy
python-scipy
python-specutils ))
- (native-inputs
- (list python-pytest
- python-pytest-astropy
- python-setuptools-scm))
(home-page "https://github.com/spacetelescope/synphot_refactor")
(synopsis "Synthetic photometry using Astropy")
(description