aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-16 19:55:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-16 19:55:28 +0100
commite64960bd7edfdbd0ea99c68705526bcc778effb5 (patch)
tree8e4ac1d2119db2d303364d19f10d66a9c138be85 /gnu/packages/astronomy.scm
parentff7d4d821a033bfd77b8cbb00339738570bac3bc (diff)
downloadguix-e64960bd7edfdbd0ea99c68705526bcc778effb5.tar.gz
guix-e64960bd7edfdbd0ea99c68705526bcc778effb5.zip
gnu: siril: Adjust indentation.
* gnu/packages/astronomy.scm (siril): Adjust indentation. Change-Id: I46de4b010f42ca74792e9a40c285e7c88b5fc741
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm73
1 files changed, 38 insertions, 35 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 03c7bb84e9..212650630c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1553,48 +1553,51 @@ crowded star fields.")
(list
#:glib-or-gtk? #t
#:imported-modules `(,@%meson-build-system-modules (guix build
- glib-or-gtk-build-system))
+ glib-or-gtk-build-system))
#:modules '((guix build meson-build-system)
((guix build glib-or-gtk-build-system)
#:prefix glib-or-gtk:)
(guix build utils))
- #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
- (assoc-ref glib-or-gtk:%standard-phases
- 'generate-gdk-pixbuf-loaders-cache-file))
- (add-after 'install 'wrap-program
- (lambda* _
- (wrap-program (string-append #$output "/bin/siril")
- ;; Wrapping GDK_PIXBUF_MODULE_FILE to load icons in
- ;; pure environments.
- `("GDK_PIXBUF_MODULE_FILE" =
- (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))
- (native-inputs (list cmake git libconfig pkg-config))
- (inputs (list cfitsio
- (librsvg-for-system)
- exiv2
- ffms2
- fftwf
- gsl
- gdk-pixbuf
- gtk+
- json-glib
- libheif
- bash-minimal ;for wrap-program
- libraw
- librtprocess
- opencv))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'generate-gdk-pixbuf-loaders-cache-file))
+ (add-after 'install 'wrap-program
+ (lambda* _
+ (wrap-program (string-append #$output "/bin/siril")
+ ;; Wrapping GDK_PIXBUF_MODULE_FILE to load icons in pure
+ ;; environments.
+ `("GDK_PIXBUF_MODULE_FILE" =
+ (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))
+ (native-inputs
+ (list cmake git libconfig pkg-config))
+ (inputs
+ (list cfitsio
+ (librsvg-for-system)
+ exiv2
+ ffms2
+ fftwf
+ gsl
+ gdk-pixbuf
+ gtk+
+ json-glib
+ libheif
+ bash-minimal ;for wrap-program
+ libraw
+ librtprocess
+ opencv))
(home-page "https://siril.org/")
(synopsis "Image processing software for amateur astronomy")
(description
- "This package provides an astronomical image processing tool - SIRIL. It is
-specially tailored for noise reduction and improving the signal/noise ratio of
-an image from multiple captures, as required in astronomy. SIRIL can align
-automatically or manually, stack and enhance pictures from various file formats,
-even image sequence files (films and SER files). It works well with limited
-system resources, like in embedded platforms, but is also very fast when run on
-more powerful computers and provides conversion to FITS from a large number of
-image formats.")
+ "This package provides an astronomical image processing tool - SIRIL. It
+is specially tailored for noise reduction and improving the signal/noise ratio
+of an image from multiple captures, as required in astronomy. SIRIL can align
+automatically or manually, stack and enhance pictures from various file
+formats, even image sequence files (films and SER files). It works well with
+limited system resources, like in embedded platforms, but is also very fast
+when run on more powerful computers and provides conversion to FITS from a
+large number of image formats.")
(license license:gpl3+)))
(define-public splash