aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 19:52:25 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 08:58:22 +0000
commit5725688923c6bfea89e6a8aed91e88bc9ef6cf49 (patch)
tree4bc248b9d994735fe7d26cc6fa316e24acb32178 /gnu/packages/astronomy.scm
parentf4831760a90524992c98a4b67a929818875b8df8 (diff)
downloadguix-5725688923c6bfea89e6a8aed91e88bc9ef6cf49.tar.gz
guix-5725688923c6bfea89e6a8aed91e88bc9ef6cf49.zip
gnu: imppg: Disable tests on non x86_64 architectures.
Tests regretion after update to the latest version as seen in CI log <https://ci.guix.gnu.org/build/6720267/log/raw>. * gnu/packages/astronomy.scm (imppg) [arguments]<test-flags>: Silent tests on non x86_64 architectures, report upstream as well. Change-Id: I875350ac60dc2f6a72eb1216a614d8943d41f9ed
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f400877ffe..ff949146a7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -916,6 +916,10 @@ dynamic library for the C language implementation of HEALPix.")
(sha256
(base32 "13kqvl9ay4x0ia7iikxbhg96pp46f1awr382p05gxdvsxksq900v"))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ ;; See <https://github.com/GreatAttractor/imppg/issues/28>.
+ #:tests? (target-x86-64?)))
(native-inputs
(list boost pkg-config))
(inputs