aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-21 21:47:50 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:46 +0000
commit4181877dcdf377ca93a7ee116120044df5cbc014 (patch)
tree256da56a2f6bd9834a6bc94812cd1304f256a6c2 /gnu/packages/astronomy.scm
parent23f282229fef9de636e468806115601ec11663d1 (diff)
downloadguix-4181877dcdf377ca93a7ee116120044df5cbc014.tar.gz
guix-4181877dcdf377ca93a7ee116120044df5cbc014.zip
gnu: python-yt-astro-analysis: Adjust inputs.
* gnu/packages/astronomy.scm (python-yt-astro-analysis) [native-inputs]: Remove python-nose; add python-pytest. Change-Id: I0b08ced355e739f1522cc749ea96db65413dc7b5
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b14456ef01..547e216043 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -6648,8 +6648,9 @@ using (multivariate) polynomials.")
(build-system pyproject-build-system)
(arguments
(list
- ;; Disable test which require MPI setup and failed to run, check why.
- #:test-flags #~(list "--ignore=test_halo_finders_ts.py")
+ ;; Disable test which requires MPI setup and failed to run, check why.
+ #:test-flags
+ #~(list "--ignore=yt_astro_analysis/halo_analysis/tests/test_halo_finders_ts.py")
#:phases
#~(modify-phases %standard-phases
(add-before 'check 'build-extensions
@@ -6657,9 +6658,9 @@ using (multivariate) polynomials.")
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(native-inputs
(list python-cython
- python-nose
- python-tomli
+ python-pytest
python-setuptools
+ python-tomli
python-wheel))
(propagated-inputs
(list python-h5py