aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:43:06 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:43:06 +0200
commitd726b954baaeff876ce9728e00920fa45f529f9a (patch)
tree4b767b7586a1082dd2691bc33c3e45ace044e6e5 /gnu/packages/assembly.scm
parent9a74a7db8626bc139307d115f5cec2648f5273ad (diff)
parente165a2492d73d37c8b95d6970d453b9d88911ee6 (diff)
downloadguix-d726b954baaeff876ce9728e00920fa45f529f9a.tar.gz
guix-d726b954baaeff876ce9728e00920fa45f529f9a.zip
Merge branch 'master' into core-updates
Conflicts: gnu/packages/ruby.scm
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm142
1 files changed, 135 insertions, 7 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index c9582bc596..6587dc5aa2 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Andy Tai <atai@atai.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,6 +48,7 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages python)
#:use-module (gnu packages sphinx)
+ #:use-module (gnu packages shells)
#:use-module (gnu packages xml)
#:use-module ((guix utils)
#:select (%current-system)))
@@ -259,16 +261,16 @@ runtime")
(define-public rgbds
(package
(name "rgbds")
- (version "0.4.0")
+ (version "0.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/rednex/rgbds.git")
+ (url "https://github.com/rednex/rgbds")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "15680964nlsa83nqgxk7knxajn98lddz2hg6jnn8ffmnms5wdam7"))))
+ "05djzl3h18zg2z5p2a881wjbmgikzkhf67cgk00frhw4v05sq0lf"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -306,21 +308,21 @@ package for the Game Boy and Game Boy Color. It consists of:
(define-public wla-dx
(package
(name "wla-dx")
- (version "9.10")
+ (version "9.11")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/vhelin/wla-dx.git")
+ (url "https://github.com/vhelin/wla-dx")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "022isf7s9q5i0j4xj69zpp0lgw8p9n37sn7ii25v68r15zaahk2w"))))
+ "0i8pxvyaih79pqnyvqyqd9rwdid91pna76cap0k1n5zhg8xswf2f"))))
(build-system cmake-build-system)
(native-inputs
`(("sphinx" ,python-sphinx))) ; to generate man pages
(arguments
- `(#:tests? #f)) ; no tests
+ `(#:tests? #f)) ; no tests
(home-page "https://github.com/vhelin/wla-dx")
(synopsis "Assemblers for various processors")
(description "WLA DX is a set of tools to assemble assembly files to
@@ -371,3 +373,129 @@ It understands mnemonics and generates code for NMOS 6502s (such
as 6502A, 6504, 6507, 6510, 7501, 8500, 8501, 8502 ...),
CMOS 6502s (65C02 and Rockwell R65C02) and the 65816.")
(license license:gpl2)))
+
+(define-public armips
+ (package
+ (name "armips")
+ (version "0.11.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Kingcom/armips")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c4dhjkvynqn9xm2vcvwzymk7yg8h25alnawkz4z1dnn1z1k3r9g"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "./armipstests" "../source/Tests")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "armips" (string-append (assoc-ref outputs "out")
+ "/bin"))
+ #t)))))
+ (home-page "https://github.com/Kingcom/armips")
+ (synopsis "Assembler for various ARM and MIPS platforms")
+ (description
+ "armips is an assembler with full support for the MIPS R3000, MIPS R4000,
+Allegrex and RSP instruction sets, partial support for the EmotionEngine
+instruction set, as well as complete support for the ARM7 and ARM9 instruction
+sets, both THUMB and ARM mode.")
+ (license license:expat)))
+
+(define-public intel-xed
+ (package
+ (name "intel-xed")
+ (version "11.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intelxed/xed")
+ (commit version)))
+ (sha256 (base32 "1jffayski2gpd54vaska7fmiwnnia8v3cka4nfyzjgl8xsky9v2s"))
+ (file-name (git-file-name name version))
+ (patches (search-patches "intel-xed-fix-nondeterminism.patch"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("python-wrapper" ,python-wrapper)
+ ("tcsh" ,tcsh)
+ ;; As of the time of writing this comment, mbuild does not exist in the
+ ;; Python Package Index and seems to only be used by intel-xed, so we
+ ;; opt to include it here instead of packaging separately. Note also
+ ;; that the git repository contains no version tags, so we directly
+ ;; reference the "version" variable from setup.py instead.
+ ("mbuild"
+ ,(let ((name "mbuild")
+ (version "0.2496"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intelxed/mbuild.git")
+ (commit "5304b94361fccd830c0e2417535a866b79c1c297")))
+ (sha256
+ (base32
+ "0r3avc3035aklqxcnc14rlmmwpj3jp09vbcbwynhvvmcp8srl7dl"))
+ (file-name (git-file-name name version)))))))
+ (outputs '("out" "lib"))
+ (arguments
+ `(#:phases
+ ;; Upstream uses the custom Python build tool `mbuild', so we munge
+ ;; gnu-build-system to fit. The build process for this package is
+ ;; documented at https://intelxed.github.io/build-manual/.
+ (let* ((build-dir "build")
+ (kit-dir "kit"))
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((mbuild (assoc-ref inputs "mbuild")))
+ (setenv "PYTHONPATH" (string-append
+ (getenv "PYTHONPATH") ":" mbuild))
+ (invoke "./mfile.py"
+ (string-append "--build-dir=" build-dir)
+ (string-append "--install-dir=" kit-dir)
+ "examples"
+ "doc"
+ "install"))))
+ (replace 'check
+ (lambda _
+ ;; Skip broken test group `tests/tests-avx512pf'.
+ (invoke "tests/run-cmd.py"
+ (string-append "--build-dir=" kit-dir "/bin")
+ "--tests" "tests/tests-base"
+ "--tests" "tests/tests-avx512"
+ "--tests" "tests/tests-cet"
+ "--tests" "tests/tests-via"
+ "--tests" "tests/tests-syntax"
+ "--tests" "tests/tests-xop")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (assoc-ref outputs "lib")))
+ (copy-recursively (string-append kit-dir "/bin")
+ (string-append out "/bin"))
+ (copy-recursively (string-append kit-dir "/include")
+ (string-append lib "/include"))
+ (copy-recursively (string-append kit-dir "/lib")
+ (string-append lib "/lib"))
+ #t)))))))
+ (home-page "https://intelxed.github.io/")
+ (synopsis "Encoder and decoder for x86 (IA32 and Intel64) instructions")
+ (description "The Intel X86 Encoder Decoder (XED) is a software library and
+for encoding and decoding X86 (IA32 and Intel64) instructions. The decoder
+takes sequences of 1-15 bytes along with machine mode information and produces
+a data structure describing the opcode, operands, and flags. The encoder takes
+a similar data structure and produces a sequence of 1 to 15 bytes. Disassembly
+is essentially a printing pass on the data structure.
+
+The library and development files are under the @code{lib} output, with a
+family of command line utility wrappers in the default output. Each of the cli
+tools is named like @code{xed*}. Documentation for the cli tools is sparse, so
+this is a case where ``the code is the documentation.''")
+ (license license:asl2.0)))
n't output 'nix/scripts/substitute'. * nix/libstore/build.cc (SubstitutionGoal)[subs, sub, hasSubstitute]: Remove. [tryNext]: Make private. (SubstitutionGoal::SubstitutionGoal, SubstitutionGoal::init): Remove now unneeded initializers. (SubstitutionGoal::tryNext): Adjust to assume a single substituter: call 'amDone' upfront when we couldn't find substitutes. (SubstitutionGoal::tryToRun): Adjust to run 'guix substitute' via 'settings.guixProgram'. (SubstitutionGoal::finished): Call 'amDone(ecFailed)' upon failure instead of setting 'state' to 'tryNext'. * nix/libstore/globals.hh (Settings)[substituters]: Remove. * nix/libstore/local-store.cc (LocalStore::~LocalStore): Adjust to handle a single substituter. (LocalStore::startSubstituter): Remove 'path' parameter. Adjust to invoke 'settings.guixProgram'. Don't refer to 'run.program', which no longer exists. (LocalStore::querySubstitutablePaths): Adjust for 'runningSubstituters' being a singleton instead of a list. (LocalStore::querySubstitutablePathInfos): Likewise, and remove 'substituter' parameter. * nix/libstore/local-store.hh (RunningSubstituter)[program]: Remove. (LocalStore)[runningSubstituters]: Remove. [runningSubstituter]: New field. [querySubstitutablePathInfos]: Remove 'substituter' parameter. [startSubstituter]: Remove 'substituter' parameter. * nix/nix-daemon/guix-daemon.cc (main): Remove references to 'settings.substituters'. * nix/nix-daemon/nix-daemon.cc (performOp): Ignore the user's "build-use-substitutes" value when 'settings.useSubstitutes' is false. Ludovic Courtès 2019-09-08daemon: Run 'guix offload' directly....* nix/scripts/offload.in: Remove. * nix/local.mk (nodist_pkglibexec_SCRIPTS) [BUILD_DAEMON_OFFLOAD]: Remove 'scripts/offload'. * config-daemon.ac: Don't output 'nix/scripts/offload'. * build-aux/pre-inst-env.in: Don't set 'NIX_BUILD_HOOK'. * nix/libstore/build.cc (HookInstance::HookInstance): Run 'guix offload'. (DerivationGoal::tryBuildHook): Remove reference to 'NIX_BUILD_HOOK'. * nix/nix-daemon/guix-daemon.cc (main) [HAVE_DAEMON_OFFLOAD_HOOK]: Don't set 'NIX_BUILD_HOOK'. * nix/nix-daemon/nix-daemon.cc (performOp) [!HAVE_DAEMON_OFFLOAD_HOOK]: Leave 'settings.useBuildHook' unchanged. Ludovic Courtès 2019-09-08daemon: Run 'guix perform-download' directly....* nix/scripts/download.in: Remove. * nix/local.mk (nodist_pkglibexec_SCRIPTS): Remove 'scripts/download'. * config-daemon.ac: Don't output 'nix/scripts/download'. * nix/libstore/builtins.cc (builtinDownload): Invoke 'guix perform-download' directly. Ludovic Courtès 2019-09-08daemon: Run 'guix authenticate' directly....* nix/scripts/authenticate.in: Remove. * nix/local.mk (nodist_pkglibexec_SCRIPTS): Remove scripts/authenticate. * config-daemon.ac: Don't output 'nix/scripts/authenticate'. * nix/libstore/local-store.cc (runAuthenticationProgram): Run 'guix authenticate'. Ludovic Courtès 2019-09-08daemon: Invoke 'guix gc --list-busy' instead of 'list-runtime-roots'....* nix/scripts/list-runtime-roots.in: Remove. * guix/store/roots.scm (%proc-directory): New variable. (proc-file-roots, proc-exe-roots, proc-cwd-roots) (proc-fd-roots, proc-maps-roots, proc-environ-roots) (referenced-files, canonicalize-store-item, busy-store-items): New procedures, taken from 'list-runtime-roots.in'. * nix/libstore/globals.hh (Settings)[guixProgram]: New field. * nix/libstore/globals.cc (Settings::processEnvironment): Initialize 'guixProgram'. * nix/libstore/gc.cc (addAdditionalRoots): Drop code related to 'NIX_ROOT_FINDER'. Run "guix gc --list-busy". * nix/local.mk (nodist_pkglibexec_SCRIPTS): Remove 'scripts/list-runtime-roots'. * config-daemon.ac: Don't output nix/scripts/list-runtime-roots. * build-aux/pre-inst-env.in: Don't set 'NIX_ROOT_FINDER'. Set 'GUIX'. * doc/guix.texi (Invoking guix gc): Document '--list-busy'. * guix/scripts/gc.scm (show-help, %options): Add "--list-busy". (guix-gc)[list-busy]: New procedure. Handle the 'list-busy' action. Ludovic Courtès 2019-08-30daemon: Don't reply on 'st_blocks'....Ported by Ludovic Courtès <ludo@gnu.org> from <https://github.com/NixOS/nix/commit/a2c4fcd5e9782dc8d2998773380c7171ee53b813>. * nix/libstore/gc.cc (LocalStore::removeUnusedLinks): Use 'st.st_size' instead of 'st.st_blocks * 512'. * nix/libutil/util.cc (_deletePath): Likewise. Eelco Dolstra 2019-06-13daemon: Replace "illegal" by "invalid" in error messages....* nix/libstore/build.cc (parseReferenceSpecifiers): Replace "illegal" by "invalid". * nix/libstore/globals.cc (Settings::pack): Likewise. * nix/libstore/store-api.cc (checkStoreName): Likewise. Ludovic Courtès