aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-01 22:21:09 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-01 22:21:09 +0200
commit8de4131b2ddd11faa3394cf497484563068c9e7a (patch)
treeed4ed9e586c7236f09c109afdd416dac18ba8cc3 /gnu/packages/assembly.scm
parent15406013fe63f2ab238eec2d7a8adbc586806ac8 (diff)
parent45b7a8bfda5bde2e2daee4bec0ca092cd719d726 (diff)
downloadguix-8de4131b2ddd11faa3394cf497484563068c9e7a.tar.gz
guix-8de4131b2ddd11faa3394cf497484563068c9e7a.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm45
1 files changed, 24 insertions, 21 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 104e61f63f..4494c475ce 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -186,14 +186,14 @@ speed on x86, NEON on ARM, etc.).")
(define-public fasm
(package
(name "fasm")
- (version "1.73.30")
+ (version "1.73.31")
(source
(origin
(method url-fetch)
(uri (string-append "https://flatassembler.net/fasm-"
version ".tgz"))
(sha256
- (base32 "00giqb94z8cxhv20yiyk8axkd2kzjcg1c0841yzbn7c8lm8m06bm"))))
+ (base32 "1qqg1czr9dr73l4gwrwim85mjs65al7vv8b292jipywimhhwnf4g"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests exist
@@ -346,7 +346,7 @@ package for the Game Boy and Game Boy Color. It consists of:
(define-public wla-dx
(package
(name "wla-dx")
- (version "10.1")
+ (version "10.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -355,20 +355,21 @@ package for the Game Boy and Game Boy Color. It consists of:
(file-name (git-file-name name version))
(sha256
(base32
- "1nh2k2xn5fj389gq68f3fxgrxakgn8c6dw2ffqay86s3706hac9w"))))
+ "1h6apmhaks4772s2cja34ck488p8yhb3nscbxjw5061ml2046zqq"))))
(build-system cmake-build-system)
(native-inputs (list python-sphinx)) ; to generate man pages
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'copy-tests-to-build-directory
- (lambda _
- (copy-recursively "../source/tests" "tests")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (let ((sh (which "sh")))
- (when tests?
- (invoke sh "../source/run_tests.sh"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'copy-tests-to-build-directory
+ (lambda _
+ (copy-recursively "../source/tests" "tests")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (let ((sh (which "sh")))
+ (when tests?
+ (invoke sh "../source/run_tests.sh"))))))))
(home-page "https://github.com/vhelin/wla-dx")
(synopsis "Assemblers for various processors")
(description "WLA DX is a set of tools to assemble assembly files to
@@ -395,21 +396,23 @@ Supported architectures are:
(define-public xa
(package
(name "xa")
- (version "2.3.12")
+ (version "2.3.14")
(source (origin
(method url-fetch)
(uri (string-append "https://www.floodgap.com/retrotech/xa"
"/dists/xa-" version ".tar.gz"))
(sha256
(base32
- "0107zdwc2rzlp26pyx7gns4lqmiyg68nmpgwrg36yrrd04v1bzgq"))))
+ "0bph41aglxl07rnggrir2dl1x97f52hm0bl51d0vklyqvfyvm6qv"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; TODO: custom test harness, not sure how it works
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)) ; no "configure" script
- #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+ (list
+ #:tests? #f ; TODO: custom test harness, not sure how it works
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)) ; no "configure" script
+ #:make-flags
+ #~(list (string-append "DESTDIR=" #$output)))) ; no $prefix support
(native-inputs (list perl))
(home-page "https://www.floodgap.com/retrotech/xa/")
(synopsis "Two-pass portable cross-assembler")