aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/android.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
downloadguix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.tar.gz
guix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.zip
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 11e05dced9..c3101bcc86 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages pcre)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -737,6 +738,7 @@ file system.")
"11as7n2mj3nbqsqb3ivyv9985n73i022s748qvjg36cs8ig50afx"))))
(build-system pyproject-build-system)
(inputs (list python-requests python-argcomplete python-urllib3 gnupg))
+ (native-inputs (list python-setuptools python-wheel))
(arguments
(list #:phases #~(modify-phases %standard-phases
(add-before 'build 'patch-gnupg