aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorHendursaga <hendursaga@aol.com>2022-09-04 11:31:29 -0400
committerAndreas Enge <andreas@enge.fr>2022-09-12 17:35:35 +0200
commitf3130fc7d9cbfe13b7deb637c6bd9b666d0f1330 (patch)
tree4a87027f811e1cc835958e8982d1b327b74d5bb9 /gnu/packages/algebra.scm
parent25d88eb9f3e22816180c099502a3a919bbe602f6 (diff)
downloadguix-f3130fc7d9cbfe13b7deb637c6bd9b666d0f1330.tar.gz
guix-f3130fc7d9cbfe13b7deb637c6bd9b666d0f1330.zip
gnu: cmh: Update to 1.1.1.
* gnu/packages/algebra.scm (cmh): Update to 1.1.1. * gnu/packages/patches/cmh-support-fplll.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm47
1 files changed, 23 insertions, 24 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index e5bd12eeb8..87fcca746b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -294,34 +294,33 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(define-public cmh
(package
- (name "cmh")
- (version "1.1.0")
- (source (origin
- (method url-fetch)
- ;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
- (uri (string-append "http://www.multiprecision.org/downloads/cmh-"
- version ".tar.gz"))
- (sha256
- (base32
- "1ws2yhzxmm2l5xqqqcjcimmg40f9qq5l9i6d4i5434an9v9s8531"))
- (patches (search-patches "cmh-support-fplll.patch"))))
- (build-system gnu-build-system)
- (inputs
- (list gmp
- mpfr
- mpc
- mpfrcx
- fplll
- pari-gp))
- (synopsis "Igusa class polynomial computations")
- (description
- "The CMH software computes Igusa (genus 2) class polynomials, which
+ (name "cmh")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ ;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
+ (uri (string-append
+ "https://www.multiprecision.org/downloads/cmh-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0nadvqfmidgks1s7aljsf8dp32pz7vjaxyaym36m9bx4zr8msk91"))))
+ (build-system gnu-build-system)
+ (inputs (list gmp
+ mpfr
+ mpc
+ mpfrcx
+ fplll
+ pari-gp))
+ (synopsis "Igusa class polynomial computations")
+ (description
+ "The CMH software computes Igusa (genus 2) class polynomials, which
parameterize the CM points in the moduli space of 2-dimensional abelian
varieties, i.e. Jacobians of hyperelliptic curves.
It can also be used to compute theta constants at arbitrary
precision.")
- (license license:gpl3+)
- (home-page "http://www.multiprecision.org/cmh/home.html")))
+ (license license:gpl3+)
+ (home-page "https://www.multiprecision.org/cmh/home.html")))
(define-public giac
(package