aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-13 02:03:22 -0400
committerLeo Famulari <leo@famulari.name>2016-05-13 02:08:11 -0400
commiteb74eb4199db3faac654114257996f244ec308f5 (patch)
tree9504ae968710941557be6d1edd244618eeb14448 /gnu/packages/algebra.scm
parentf10e7ef475da430afa46e0b062010952ed886694 (diff)
parente9017c98d61f305b624bacaa30e8891ec0100980 (diff)
downloadguix-eb74eb4199db3faac654114257996f244ec308f5.tar.gz
guix-eb74eb4199db3faac654114257996f244ec308f5.zip
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index f03c3c104e..53f6f3e3d2 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -24,7 +24,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
- #:use-module (gnu packages doxygen)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages gl)
#:use-module (gnu packages graphviz)
hases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "Kvantum")))
+ (add-after 'chdir 'patch-style-dir
+ (lambda _
+ (substitute* "style/CMakeLists.txt"
+ (("\\$\\{KVANTUM_STYLE_DIR\\}")
+ (string-append #$output
+ "/lib/qt5/plugins/styles"))))))))
+ (native-inputs (list qttools-5))
+ (inputs (list
+ kwindowsystem
+ libx11
+ libxext
+ qtbase-5
+ qtsvg-5
+ qtx11extras))
+ (synopsis "SVG-based theme engine for Qt")
+ (description
+ "Kvantum is an SVG-based theme engine for Qt,
+tuned to KDE and LXQt, with an emphasis on elegance, usability and
+practicality.")
+ (home-page "https://github.com/tsujan/Kvantum")
+ (license license:gpl3+)))
+
(define-public materialdecoration
(let ((commit "6a5de23f2e5162fbee39d16f938473ff970a2ec0")
(revision "9"))